Hi All,
Up until about a month ago, everything was running fine.

I have a sever with a hostname of nexus on my local network. I used to be able to surf over to it via any browser using http:\\nexus:port\ without issue. Then browsers were updated and that no longer worked. My browsers forced https when I tried to access that host (the only host running any services on my network other than openwrt) - the reason I >think< this is happening is because .nexus is a tld owned by google and updated browsers force https to it per hsts. "nexus" cannot be removed from being forced to https in chrome at least. Older versions of browsers continue to work though (ie firefox 94 works while 96 does not).

Is there any way for me to set up dnsmaq to be able to continue to surf to just the name "nexus" in a browser without having to add a a tld like .lan or .local, please?

Thank you

Error when surfing to http:\\nexus:9000\ (Portainer):

Router information:

|Model|Netgear Nighthawk X4S R7800|
|Architecture|ARMv7 Processor rev 0 (v7l)|
|Firmware Version|OpenWrt 19.07.4 r11208-ce6496d796 / LuCI openwrt-19.07 branch git-22.025.78315-f3debdc|
|Kernel Version|4.14.195|

dnsmasq 2.80-16.3

Image capture of Network-> DHCP & DNS settings:

It's not a DNS issue, it's a browser 'issue'. So no, there's not going to be a way to set up dnsmasq to override the browser forcing the connection to https.

1 Like