DNS does not work for repeater/bridge

I have been using OpenWRT for a number of years but just recently started using 21.02.1.
I have normally used a repeater/bridge to connect my home office to my main router.
Both of these devices are now using 21.02.1.
My repeater hardware is a TP-Link Archer c7 v2.
The issue I am experiencing is that although DNS is working from the remote network itself,
DNS is not working from within the repeater router.
For example, if I go to "Diagnostics" and ping a named, external, destination, it fails.
If I ping an actual external address, it succeeds.
So what is the problem? Software upgrades and installs fail, they are expecting
repository names to be resolved, and they are not.
Does anyone have any ideas where I should look to resolve this?

Thanks greatly and I hope to post a network config file shortly.

Static IP?
Did you manually add DNSes?

Just to preempt any potential issues:

Installing new packages is fine. Be aware of the following warning about upgrading existing packages:

Upgrading packages (via the CLI opkg upgrade command or the LuCI Upgrade... button) can result in major problems. It is generally highly discouraged, unless you know what you are doing or if there is specific instruction to do so.

As @frollic said, you need to make sure that you have DNS entered in if you've set your AP's network via static. You will also need to make sure it has the gateway defined.

All IPs within the repeater/bridge are static.
All DNS requests are forwarded to my other router which in turn uses the ISPs DNS.

Thank you for the advice. I will pay closer attention to the upgrades in the future.
Never the less, if I need to add a new package, I am unable to resolve the name
for the package repository.
I am using static addresses throughout and attempting to forward all DNS requests
to my central AP/router. This, in turn, uses the server addresses provided by my ISP.

Post your/etc/config/network file

and /etc/resolv.conf

My /etc/resolve is below...

*search lan*
*nameserver ::1*

and what about your network file?

my /etc/config/network is below...

*config interface 'loopback'*
*	option device 'lo'*
*	option proto 'static'*
*	option ipaddr ''*
*	option netmask ''*

*config globals 'globals'*
*	option ula_prefix 'fd8c:1106:9328::/48'*

*config device*
*	option name 'br-lan'*
*	option type 'bridge'*
*	list ports 'eth1.1'*

*config interface 'lan'*
*	option device 'br-lan'*
*	option proto 'static'*
*	option netmask ''*
*	option ip6assign '60'*
*	option ipaddr '192.168.XXX.25'*
*	option gateway '192.168.XXX.205'*
*	list dns '192.168.XXX.205'*

*config switch*
*	option name 'switch0'*
*	option reset '1'*
*	option enable_vlan '1'*

*config switch_vlan*
*	option device 'switch0'*
*	option vlan '1'*
*	option ports '2 3 4 5 0t'*

*config switch_vlan*
*	option device 'switch0'*
*	option vlan '2'*
*	option ports '1 6t'*

*config interface 'fficbridge'*
*	option proto 'relay'*
*	option ipaddr '192.168.XXX.26'*
*	list network 'Aivan11AC'*
*	list network 'lan'*

*config interface 'Aivan11AC'*
*	option proto 'static'*
*	option ipaddr '192.168.XXX.24'*
*	option netmask ''*
*	option gateway '192.168.XXX.205'*
*	list dns '192.168.XXX.205'*

Is this the correct gateway and dns server for your network? For the hosts that connect to this bridge and operate normally, do they use these same addresses?

EDIT: in the future, please don't redact RFC1918 addresses. They do not reveal anything sensitive as they are not publicly routable addresses.

And if you would add nameserver to resolve.conf?

All devices are to home on the AP, the "205" address.

I will try that out.