DNS & DHCP dnsmasq ? - Need external DNS/DHCP

Hi Guys... so... an update.
Meraki MR16 Latest Version of OpenWRT (compiled 26 Jun 2019)
I ONLY want these to be basic AP's with SSIDs and WPS2 etc.
I have them ALMOST working, except the DNS
I can connect with a Laptop or Android device and DHCP gets passed through from my ISP Cable Router with ISP DNS server entries.
but... the OpenWRT MR16s cannot resolve domain names....
therefore - NO working NTP
No working software updates
can't add packages... etc...
Could someone point me to the right place to add 192.168.0 1 - 8.8.8.8 and 8.8.4.4 as DNS name servers that the AP will query on the eth0 port please?
ISP Router has 1Gbps Switch built in and I'm using Power Bricks for the Meraki MR16s' at the moment

Thanks in Advance.
Wayne

Just add the DNS servers on the same page where you configured the LAN IPs.

If you're using command line, that's under the LAN section in /etc/config/network

Strange how you can read and learn something new.
I ended up fixing this myself.

from a terminal session:-
vi /etc/config/network
press the letter i once to enter edit mode

config interface 'lan'
option type bridge
option ifname 'eth0'
option proto 'static'
option ipaddr '192.168.x.x' //your lan IP Address here
option netmask '255.255.255.02 //your subnet mask here
option dns '192.168.x.x 8.8.8.8 8.8.4.4' //your dns server ip addresses here
option ip6assign '60'
option peerdns '0'
option gateway '192.168.x.x' //your default gateway here
option broadcast '192.168.x.255' //your broadcastr address here - although not needed
Press Esc
type :x followed by enter to exit and save

then:-
vi /etc/resolv.conf
enter edit mode
mine showed:-

Interface lan

nameserver 127.0.0.1

change name server to your preferred DNS
add additional nameserver lines to suit
for example

Interface lan

nameserver 192.168.x.x //your internal dns server or routers IP
nameserver 8.8.8.8
nameserver 8.8.4.4

press esc type :x and quit.
I usually do a reboot when I'm done... that way I know it will come back up when i move it..

Thanks lleachii, but...
mine didn't work without manually editing the resolv.conf file

so far - so good!

After editing, reboot or run:

/etc/init.d/network reload
/etc/init.d/dnsmasq reload

It's not advised to edit that file; but glad you got it working.

1 Like

I agree - but it wouldn't work any other way.