DNS and WiFi problems, need to restart router several times a day


Im a new OpenWRT user with limited networking skills so please forgive me if I don't use the correct terms.

I installed OpenWRT on my TP-Link Archer C2 router using this piece of software:

I created 2 WiFi networks (one for personal use, other for a company PC). I use several devices:
PC connected via Ethernet cable
a few Wifi devices.

I encounter the following problems:

  1. Every few hours I get the DNS errors when browsing the web on my PC (IP address not found). To fix it I have to restart the router. I tried both using both ISP DNS and Google DNS. I don't seem to have that problem on the company PC which uses the corporate DNS via VPN.
  2. Sometimes the WiFi networks are inaccessible (sometimes both, sometimes just one). Hard to tell what's wrong.
  3. Very often when I want to restart the router because of DNS problems, I can't connect to LuCI. When I go to the IP address is not found. I can only restart the router by physically pressing the button.

Please help me fix/investigate these problems.
I tried updating all the software packages on the router but it didn't solve the problem.

Maybe the CPU is overwhelmed by some process?
What does top command show?
Also check the memory with free command and the disc space with df -h command.
Post the output here using preformatted text </>
To access the router from SSH check the guide.

1 Like

this is actually a bad idea and guaranteed to cause problems, the opkg system is not designed for this. save your config, and reflash your device with a fresh flash, then restore just the packages you want and the configs

1 Like

CPU seems to be fine, there is plenty of free memory and disk space.

Thanks for the tip. I can do this but I'm pretty sure it won't solve my problems since I've had them for a long time with older package versions.

Maybe there is something wrong with my configuration?
Is there a reason for DNS shutting down and the Luci to be unavailable?

Do you have any wired clients you can compare connectivity with?

You can post your config here, but if it works and then it stops, you should run some troubleshooting commands when it is happening.

uci show network;uci show wireless; \
uci show firewall; uci show dhcp; \
ip -4 addr ; ip -4 ro ; ip -4 ru; \
ip -6 addr ; ip -6 ro ; ip -6 ru; \
iptables-save; ip6tables-save; \
head -n -0 /etc/firewall.user; \
ls -l  /etc/resolv.* /tmp/resolv.*; head -n -0 /etc/resolv.* /tmp/resolv.*

Please use "Preformatted text </>" for logs, scripts, configs and general console output.

An ath10k device with only 64MB of RAM should be running the mainline ath10k driver not the -ct version.

Somehow the -ct version uses an ever-increasing amount of RAM; after several minutes to hours the whole router crashes, as the out of memory killer kills off vital processes like dropbear (SSH server) and uhttpd (http server).

Install a new snapshot then remove the -ct ath10k and ath10k firmware and install ath10k (without -ct). Running snapshot builds you will usually need to reinstall the whole OS to get the kernel to match the packages.

An alternative is to fully disable the 5 GHz radio and see if the situation becomes stable.