Dmesg on OpenWrt [ gps navilock nl-8012u tty? ]

Hello everyone!!
I am trying to get the data from GPS device on OpenWrt, by using one of the guide mentioned in But the problem is that dmesg is not showing to which /dev/tty my GPS is connected and that is why i am not able to run stty -F /dev/tty*** 4800 command.
How i would know this. if dmesg is not showing any thing for this.
Thank you!!

device & openwrt version & serial hardware?

OpenWrt 18.06.1 installed on APU1D board(PC Engines) and GPS device is navilock nl-8012u

1 Like

please plug in the device and post and NEW lines that appear in dmesg in code tags ( ^ </> )

you can also install lsusb ( usbutils ) and post the output of that.

may as well also post output from;

ls -la /dev/tty*

This is the output i am getting
while in linux terminal this is the result of dmesg

Try with /dev/ttyACM1.

[Next time, please try to follow the instructions when asked for logs. A screenshot is easier for you, but harder for everybody else]


I tried. it says (stty: /dev/ttyACM1: No such file or directory)

opkg list-installed | grep usb | grep serial

This is the result :
kmod-usb-serial - 4.14.63-1
kmod-usb-serial-cp210x - 4.14.63-1
kmod-usb-serial-ftdi - 4.14.63-1
kmod-usb-serial-pl2303 - 4.14.63-1

well... you did not do 'ls -la /dev/tty*' yet... but i'm pretty sure your missing something...

  • on your pc it loads as usb3 ( may not make a difference - hid etc. )
  • there is a cdc_acm... which on openwrt might be kmod-usb-gadget-cdc-composite ( kmod-usb-gadget-hid? )
  • as for pps... there is a kmod for that too but again... i'm not sure of thats required here...

( this also kmod-usb-acm )

i tried that too, which you suggested (ls -la /dev/tty*)
that also didn't work unfortunately

Is the log showing "USB Disconnect" even though it is still plugged in? It should initialize once when plugged in and stay connected.

You may sometimes get ACM0 instead of ACM1.

Also look for it in /dev/USB or similar if not in the main /dev directory.