DLNA to sleep after a while

As in the tittle

DLNA relay goes to sleep after a while ( computers and also Samsung / LG TV )

Just a precision: the box works in relay mode without any other problem

  • What package did you install on OpenWrt?
  • What are the configs?

I have compiled last version for use relayd -> luci-proto-relayd and others packages for share disk in VFAT NFTS .and more

my config is:
Router Orange Livebox 4 <-> OpenWrt in relay mode ( some little box's as WT3020 or GL-MT300N V2 )
Similar to this :slight_smile:

All is ok only a little problem with DLNA

in Windows Devices & printers DLNA's exist but after some times are greyed
with TV Samsung / LG the DLNA box's disappear


I have stopped Openwrt firewall service and same problem

All of your devices are on the same LAN. DLNA is a LAN protocol. What is relayd used for?

Config is as this:



I have not the 2 left computers all are in right LAN also TV

Test with this config:


Let me be clear:

  • The picture in post #5 is an image from OpenWrt's Wiki.
  • Please confirm that the picture in post #6 is of your network.

You haven't explained why you setup relay client for a LAN DLNA setup.

DLNA doesn't need a relay on a LAN.

Please provide configs.

the config is as the last picture

i use the devices for some features:

1 - I can use printers ( LAN or USB ) without wires !!

2 - I use also for my 2 * TV Samsung & LG who only have wired network and i connect some HDD's with videos
It's more convenient than plugging the discs behind the TVs ( DLNA ) !!!

All is in the same LAN > -192.168.1.xx
Today I received two WR1200JS (5GHz) for use with the Livebox 4 ( 2.4 & 5Ghz )
With the first it seems to work well
Unfortunately the second one does not work (is out of hardware)
Too bad I could have seen if it was not a story of network conflict

If they're in the same LAN, the router isn't involved, and relayd isn't needed.

Yes the same LAN group address same subnet but not physical It is exactly as shown in the image of Relayd above

Exemple for the TV Samsung

My computer <-LAN WIred-> Routeur LiveBox 4 <-WIFI-> ……. <-WIFI-> OpenWrt <-LAN-> TV <-----Wired ----> <---WIFI--->… <---WIFI---> <---Wired--->

  • Same VLAN
  • Same LAN
  • Same broadcast domain
  • Doesn't matter if it's wired or wireless

No relayd needed. The OpenWrt relay is not an issue - it's not needed.

  • If you need a relay in this setup, you have improperly configured WiFi-to-LAN bridging.
  • I also asked for your relayd config; but I don't think it's needed.

relays are also to extend the reach of the wifi



config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr ''
        option netmask ''

config globals 'globals'
        option ula_prefix 'fd77:cf5f:22af::/48'

config interface 'lan'
        option type 'bridge'
        option proto 'static'
        option netmask ''
        option ip6assign '60'
        option gateway ''
        option ifname 'eth0 eth0.1 eth0.2'
        option ipaddr ''
        option dns ''

config device 'lan_dev'
        option name 'eth0.1'
        option macaddr 'ca:d0:19:00:64:58'

config device 'wan_dev'
        option name 'eth0.2'
        option macaddr 'ca:d0:19:00:64:59'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 3 6t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '4 6t'

config interface 'wwan'
        option proto 'static'
        option netmask ''
        option gateway ''
        option ipaddr ''
        option dns ''

config interface 'stabridge'
        option proto 'relay'
        list network 'lan'
        list network 'wwan'


config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11g'
        option path 'platform/10180000.wmac'
        option disabled '0'
        option legacy_rates '1'
        option country 'FR'
        option htmode 'HT20'
        option channel '3'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option mode 'ap'
        option encryption 'psk-mixed'
        option key '1234567890'
        option wpa_disable_eapol_key_retries '1'
        option network 'lan'
        option ssid 'WT3020-231'

config wifi-iface
        option ssid 'Livebox-6256'
        option device 'radio0'
        option mode 'sta'
        option bssid '8C:F8:13:29:62:56'
        option encryption 'psk-mixed'
        option key '1234567890'
        option network 'wwan lan'
        option disassoc_low_ack '0'


config defaults
        option syn_flood '1'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'

config zone
        option name 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        option network 'lan wwan'

config include
        option path '/etc/firewall.user'

config include 'miniupnpd'
        option type 'script'
        option path '/usr/share/miniupnpd/firewall.include'
        option family 'any'
        option reload '1'


config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.auto'
        option nonwildcard '1'
        option localservice '1'

config dhcp 'lan'
        option interface 'lan'
        option dhcpv6 'server'
        option ra 'server'
        option ignore '1'
        option ra_management '1'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

What does that mean?

It seem you may have improperly setup a bridge:

config interface 'stabridge'
        option proto 'relay'
        list network 'lan'
        list network 'wwan'
  • Can you explain what this interface for???
  • Why didn't you configure this device to be a wireless BRIDGE to LAN as opposed to a CLIENT to the upstream Wireless???

Your issue is that you configured your device to be a client of the upstream LAN, as opposed to bridging it to LAN. This config is incorrect, and you must have also improperly numbered the LAN connecting on this interface. I need to know if your WiFi card is Broadcom or Atheros.

in this exemple stabridge is the same 

For a WT3020 ( instable DLNA ) the WIFI Wireless chip si MediaTek / Ralink RT5390 

For a GL-MT300N V2 it seems pretty stable

With the WR1200js it seems more stable but I have only the case since yesterday

It may be a driver problem
I even compile the firmwares from openwrt sources with no other modification than to add packages

I think the issue is in order to have a transparent wireless bridge, you need WDS. If he hasn't set up WDS then it's in fact not a transparent bridge, and then relayd can be useful. The easiest thing is to set up WDS and be done, though I've found that WDS cuts out after a while randomly. I chose to use powerline gear to wire up my extra AP that used to be on WDS, and that solved my cut-out problem.

For WDS i have not this option

Tested in relayd mode :

GL-iNet MT300N V2 -> MT7628 stable

Minihere WR1200JS -> MT7621A in 5Ghz mode stable

Minihere 300Mbps -> MT7620N stable

NEXX-WT3020 ( 8 M or 16 Mo modified ) -> MT7620N unstable

I test at this time KIMAX U25CWF & U25AWH-H1 ...