DLNA server on Linksys EA6350 v3?

Has anyone managed to get the DLNA server working on the Linksys EA6350 v3? I have miniDLNA service installed but folders and files are not being found on any of my devices which detect it.

Have you installed the kernel modules required for the file system(s) on your media? In general, while USB support is provided by the basic builds, you probably need either or both the FAT and/or ext4 modules as well. kmod-usb-storage-uas, if not already installed may be of value for you to speed access to the devices, if they support UASP.

lsmod will show what you already have installed into the running kernel.

You're probably running into the issue where you have a version of libffmpeg that doesn't have all the support needed for minidlna.

Few points to check:

  • Is the USB disk accessible, as @jeff pointed out? Also if the disk happens to be NTFS then you will need to add support for that.
  • Is the media supported? Try to include different formats including video, photos and images.
  • There is also the chance that all is in place but the disk wasn't yet ready when the miniDLNA service started.

Possibly. However I have absolutely no idea how to check this, or to replace it.

mhegab - thanks for the pointers. Can you help me out on how to add NTFS support? I just used a 4GB stick so its possible I had it formatted as FAT32. I tried MP3, FLAC, WAV audio formats, along with MKV, MP4 and AVI video formats.

I tried adding a 2GB USB stick and USB storage drivers using this guide. I updated the packages ok, but after running opkg install kmod-usb-storage it fails with the following errors:

Collected errors:
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-usb-storage:
 *      kernel (= 4.14.115-1-4c9a12d50aaff432c1de0972a8a31cd1)
 * opkg_install_cmd: Cannot install package kmod-usb-storage.

So if I can't install even basic USB drivers, I doubt if I'll get the DLNA server working

What version of OpenWrt are you running? Is it the current snapshot on the device page, or is it an older install? If the latter, you may want to upgrade OpenWrt.

Have a look at this Keep getting: Cannot satisfy the following dependencies and this Kernel version mismatch when install kmod. The second link suggests using option --force-depends, so could be your resort if the snapshot you are using is the latest available but is actually using an older kernel.

Once you got past that and have USB support, you colud look at this for NTFS support
https://openwrt.org/docs/guide-user/storage/writable_ntfs.

@Mickrick
I have a very recent snapshot build with ffmpeg4 and minidlna built for this device if you're interested.

Yes that would be great. Thanks for the offer.

You have a private message :slight_smile: