DLNA is not working in Dumb AP mode


On my Linksys WRT1900ACS v1 router i changed the firmware from factory to OpenWrt 19.07, installed LUCI and followed this guide to set it Dumb AP mode (https://openwrt.org/docs/guide-user/network/wifi/dumbap). Then added this:


Since the upgrade my TV is not able to detect my NAS as a DLNA device and I can't play movies.

My network topology is the following: internet - Pfsense box - TP-Link managed switch - OpenWRT router. The NAS and the OpenWrt router is connected to the switch, and the TV is connected to one of the LAN ports of the OpenWrt router. No VLANs, everything on one subnet where pfsense acts as main router / dhcp / dns. In the same setup with the stock firmware on the router DLNA is worked. To test things I connected the NAS to the OpenWrt router LAN port next to the TV and still no DLNA :frowning:
Based the above I guess OpenWrt somehow blocking the multicast packets but cant find any info how to enable it.

  • more info: I'm runnig plex server on my nas and the xplay client on my TV is able to reach it and play movied, so the connection is ok between the 2 device.

Anyi idea? I'm going nuts but cant solve this issue :frowning:

Ok so you are saying that TV xplay client can access NAS Plex server? So what's not working?

Also can you confirm that you have DHCP turned off on your OpenWrt?

For the sake of trying, did you see what happens if you remove the managed switch?