DLNA Broadcast over multiple subnets

Hi,

I have read several threads about this topic already and tried alot of different things but unfortunately I am not able to get it working.

My setup looks like this:
Router 1: 192.168.1.0/24
Unmanaged Switch connected to Router1 LAN Port1.
DLNA Server (192.168.1.30) connected to Unmanaged Switch.
Router 2 WAN (192.168.1.40) connected to Unmanaged Switch.
Router 2 Net 192.168.2.0/24
Both, DLNA Server and Router2, are on the same interface and firewall group LAN.

Clients on LAN/Wifi on Router1 are able to discover the DLNA server.
Clients on LAN/Wifi on Router2 are not.

I read up on installing igmpproxy to solve this issue. So I installed igmpproxy on Router 2 and used this config:

config igmpproxy
        option quickleave 1

config phyint
        option network wan
        option zone wan
        option direction upstream
        list altnet 0.0.0.0/0

config phyint
        option network lan
        option zone lan
        option direction downstream

Unfortunately I am still not able to discover the DLNA Server on the 192.168.2.0 network.
I tried enabling the IGMP snooping on Router 1 and/or Router 2 but this did not work either.
Tried adding a firewall rule to allow all traffic from Router 2 to Router 1 and vice versa but did not help.
Tried disabling the firewall completly, not working.
Tried forcing IGMP Version 2 like it stated in the OpenWrt Documentation - did not help.

Current firewall rules on Router 1:

config defaults
        option input 'ACCEPT'
        option output 'ACCEPT'
        option synflood_protect '1'
        option forward 'REJECT'

config zone
        option name 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        option network 'lan'
        option masq '1'

config include
        option path '/etc/firewall.user'

config zone
        option forward 'REJECT'
        option output 'ACCEPT'
        option network 'vlan_keller'
        option name 'vlan_guests'
        option input 'ACCEPT'

config zone
        option network 'wan'
        option name 'wan'
        option mtu_fix '1'
        option forward 'REJECT'
        option masq '1'
        option output 'ACCEPT'
        option input 'REJECT'

config forwarding
        option dest 'wan'
        option src 'vlan_guests'

config forwarding
        option dest 'wan'
        option src 'lan'

config rule
        option dest_port '68'
        option src 'wan'
        option name 'Allow-DHCP-Renew'
        option family 'ipv4'
        option target 'ACCEPT'
        list proto 'udp'

config rule
        option src 'wan'
        option name 'Allow-Ping'
        option family 'ipv4'
        option target 'ACCEPT'
        list proto 'icmp'

config rule
        option src 'wan'
        option name 'Allow-IGMP'
        option family 'ipv4'
        option target 'ACCEPT'
        list proto 'igmp'

config rule
        option dest_port '67'
        option src 'vlan_guests'
        option name 'Allow-DHCP-Guest'
        option target 'ACCEPT'
        list proto 'udp'
        option family 'ipv4'

config rule
        option dest_port '53'
        option src 'vlan_guests'
        option name 'Allow-DNS-Guest'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option src 'vlan_guests'
        option name 'BlockModemAccess'
        option dest 'wan'
        option target 'REJECT'
        list dest_ip '192.168.0.0/24'

Interface settings on Router 1:

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'
        list dns '192.168.1.30'
        option delegate '0'

config interface 'wan'
        option ifname 'eth0.2'
        option proto 'dhcp'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option vid '1'
        option ports '0t 2 4 5'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '0t 1'
        option vid '2'

config switch_vlan
        option device 'switch0'
        option vlan '3'
        option ports '0t 3'
        option vid '3'

config interface 'vlan_keller'
        option ifname 'eth0.3'
        option proto 'static'
        option type 'bridge'
        option delegate '0'
        list ipaddr '192.168.2.1/24'

config route
        option target '192.168.40.0'
        option gateway '192.168.1.40'
        option netmask '255.255.255.0'
        option interface 'lan'

Current firewall rules on Router 2:

config defaults
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option synflood_protect '1'

config zone
        option name 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        option network 'lan'

config zone
        option name 'wan'
        option output 'ACCEPT'
        option masq '1'
        option mtu_fix '1'
        option network 'wan'
        option input 'ACCEPT'
        option forward 'ACCEPT'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option src_ip 'fc00::/6'
        option dest_ip 'fc00::/6'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-MLD'
        option src 'wan'
        option proto 'icmp'
        option src_ip 'fe80::/10'
        list icmp_type '130/0'
        list icmp_type '131/0'
        list icmp_type '132/0'
        list icmp_type '143/0'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-IPSec-ESP'
        option src 'wan'
        option dest 'lan'
        option proto 'esp'
        option target 'ACCEPT'

config rule
        option name 'Allow-ISAKMP'
        option src 'wan'
        option dest 'lan'
        option dest_port '500'
        option proto 'udp'
        option target 'ACCEPT'

config include
        option path '/etc/firewall.user'

config forwarding
        option dest 'lan'
        option src 'wan'

config rule
        option family 'ipv4'
        option src 'wan'
        option name 'AllowRemoteWebAcess'
        option target 'ACCEPT'

config zone
        option network 'guest'
        option input 'ACCEPT'
        option name 'guest'
        option output 'ACCEPT'
        option forward 'ACCEPT'

config forwarding
        option dest 'wan'
        option src 'guest'

Interface settings on Router 2:

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option delegate '0'
        option ipaddr '192.168.40.1'

config interface 'wan'
        option ifname 'eth0.2'
        option proto 'dhcp'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '2 3 4 5 0t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '1 0t'

config interface 'guest'
        option proto 'static'
        option netmask '255.255.255.0'
        option delegate '0'
        option ipaddr '192.168.41.1'
        option type 'bridge'

Did I miss something?
Somebody got an idea what I could try to fix my problem?
Sorry if this got answered elsehwere but I am searching and trying since 2 days and I do not know what to try anymore.

Thanks a lot for your ansewrs!

Maybe this will help.