DLink DIR-853 A3

In simple words YES..! for the first time flash via stock GUI you wont be able to flash to latest openwrt as DLink is using some sort of encryption in their firmwares. So if you try, stock GUI will return invalid image error or chances are you will brick the router and there is no recovery option except opening and soldering some wires as much as I know. So for the first time flash from stoch GUI you must use enc.bin then you can use any openwrt image to upgrade. Also to revert back you must use Decrypted stock image as openwrt is not using encryption like Dlink's else you will endup bricking the unit as well.
Hope I was able to clear your confusion...!

1 Like

Thanks brother, that definitely cleared my confusion. The encrypted image's download link and the steps of needing to flash that first definitely needs to go into the wiki.

Thanks @kar200 for your reply.

I actually wanted to move to OpenWrt but I have a big problem setting my external HDD as a shared drive, I tried everything but no luck, I don't know if the drive size is the reason since it's a 5TB drive but heh who knows, anyhow I was wondering if you can you guide me through the steps so I can get this thing working :wink:

Dears,

Can someone help me with a small guide to move from Padavan to OpenWrt, also would appreciate your thoughts, just looking for an improved performance over wifi.

@hsaber I don't think I have used the smb function with USB beyond copying files for testing. Your best bet would be to look in the forum here for other people that used the same function with a similar device (mt7621 platform). Have you tried this link?

Is your 5TB drive 2.5 or 3.5 with external power?

@kar200 Hello Kareem! First off Thanks for All the Wonderful work. Unfortunately 5Ghz wifi isn't showing on mobile device even after trying every channel and mhz setting, so reverting back to stock but I'm unable to run the mtd command. Also there are 2 tmp folders I tried putting stock firm o both and run mtd from there but still showing same error

Hi @bani,

ASAIK mtd_write is a command used in Padavan but your router already has openwrt.

It looks like you have version 22.03.2 installed wich is supposed to be the latest version as well.

Can you access the web interface? If yes try and setup the wireless from there.

Make sure the first interface is setup as 2.4 and the second one as 5. Also try to assign a country manually.

One last advice is to avoid using unless you really have to. MTD does not perform any checks (unlike sysupgrade or the web interface upgrade option in openwrt) and therefore it will just overwrite the mtd on your device even if you provide with with a jpeg image.

Yes, I tried via web interfaces and changed country as well but still same.

IT would be really appreciable if you can guide me step by step how to get stock Firmware Back from this openwrt 22.03.2 ?

@kar200 Can you please help mate

Sorry late reply I thoguht i did but apparently not!

You neer to copy the decrypted stock firmware to the /tmp partition. Then login through SSH and use the mtd command.

I cannot remember the exact command but it should be somewhing like
# mtd write file.bin firmware

The file.bin is the decrypted file. firmware (all lower case) is the partition where the firmware is that you can check by typing

cat /proc/mtd or car /proc/partitions.

I would suggest going back on this thread theres a guy that posted the a file link with all the files needed to either move to openwrt or go back to stock (with the decrypted firmware file)

I wanted to add that the the file has to be DECRYPTED and not the one from the dlink website. There should be on soemwhere here or i can check i should have it in my files somewhere