DLink DIR-853 A3

I have a DLINK DIR-853 A3 device with me, it looks like its not officially supported, though I find some people on the forum finding some way to run openWRT on this hardware.

Can someone kindly explain me the steps I should follow.

Depends on what you are after really. Is it just using pre built openwrt image on your device or building your own image?

If you want to build from source you can find them here.

Please note that the emergency room does not work using the reset button method. I cannot make it work. The only thing I could guess is that the reset gpio for this device is gpio8 and for most others new dlink routers it's gpio15 (which unfortunately is a led output on the DIR-853-A3).

I have managed to build an openwrt image that can be flashed from the stock web interface. Dlink have provided a binary called (imgcrypt) on the first version of the GPL source. I can send you the file if you want but please be aware that you might end up with a bricked device and you will have to access the console (open the router and solder some pins + USB TTL device) to be able to revive the device.

K.

1 Like

I guess I'll give it a try, followed the guide in the git page, ran 'make menuconfig', I am pretty confused on what settings I should select for the build ! any help is appreciated.

where can I find which target or sub target system I should select.

or is it easier to flash with the image you have created !

How am I going to add the support for 853 A3 into OpenWrt ? !

1 Like

See if this helps: https://openwrt.org/faq/how_do_i_send_prs_pull_requests

Would it be possible to get my hands on your firmware for dir853 a3?

Sure. Did you actually open your box or just after a flash-able one from stock web interface?

I am just asking because if you brick it there is no way to revive it without opening the box and soldering some pins.

K.

Looking for flashable from web interface. I haven't opened the box yet but I'm comfortable soldering pins if it gets bricked.

Perfect. This link contains 2 files. one of them is an encrypted openwrt with a many pakcages I thought might be useful. The other one is the stock firmware for DIR-853-A3 decrypted to go back to factory.

A few details to note:
Please keep in mind that it can brick your router.

This is not the latest MT76 drivers. Someone tested with the latest drivers and it doesn't seem to be working any better.

Also because of DBDC in the wireless card the wireless config file need to be edited manually through SSH and not via Luci.

Obviously the default IP will be 192.168.1.1.

Good luck.

EDIT: This is the sha25sums

5e1b250b2e791f33ae32f4acbb79aba057d8cc33736c7d649668072400db6bc9  openwrt853enc.bin

a5360c6a35e0c318a4d67edd0a4c43e875e8952bd608302ba3a9d7ca274a5f26  DIR-853-A3-Stock-Dec.bin

Thanks for this, i will give it try.

Let me know how you go.

Flashed and seems stable. Now just trying to familiarise myself with OpenWrt which looks a lot more configurable than ddwrt and stock firmware. Thanks again for your help.

Good. Once you get it working make sure you edit the /etc/config/wireless file as it should look like this (Luci doesn't change correctly the file).


config wifi-device 'radio0'
	option type 'mac80211'
	option channel '6' #channel of your choice
	option hwmode '11g'
	option path '1e140000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'
	option htmode 'HT40' #you can change this
	option disabled '0'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'yourSSID'
	option encryption 'psk2+ccmp'
	option key 'yourPassword'

	config wifi-device 'radio1'
	option type 'mac80211'
	option channel '40' #channel of your choice
	option hwmode '11a'
	option path '1e140000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0+1'
	option htmode 'VHT80' #same here
	option disabled '0'

	config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option ssid 'SSID5'
	option encryption 'psk2+ccmp'
	option key 'password'

how to that ?
I made it here so far

I am sorry I did not understand your question.

Hello,

I have a DIR 853 A3 as well from the ISP.
Can I please have a flashable firmware using the web interface?
The link in the thread has expired.
Regards
PT

How do we edit the /etc/config/wireless file ?

Using ssh. You connect through ssh and run

vim /etc/config/wireless

If you are using windows I noticed that winscp is a quicker and effective way to make changes through gui. Just make sure you save and reboot.

1 Like

Hi Kar200,

Really interested in getting the my hands on to the 2 files you had shared. I also have an A3 that I had from one of my previous ISP's and sitting there idle with no way to connect to the internet as it is locked to the ISP. Would like to use this as a second router/range extender if possible.

Could you kindly share the files you have created.

Thanks in advance!!

Hi Nirusha,

No worries at all. The only issue is that out of the 6 people I shared it with 3 of them managed to brick their routers (50% fail rate).

It was not due to the file I provided but more due towhat they did after that. I understand more now why Dlink has 2 levels of protections (one to flash and the other one in uboot to recover the previous firmware).

I can share it with you of course. You have a few choices in the fimrware.

Openwrt - not a good Idea at the moment as MT76 (DBDC) with DSA just make the router hang at boot time. It can be recovered though but you wont be able to do much
X-WRT - Based on Openwrt but uses swconfig instead of DSA but still the wireless driver is not the best.
Lede - Based on openwrt but uses the offical wireless MTK drivers. They are quite good actually.
Padavan - Latest build I made. Not many options in the image (although included nearly everything) but seems the best in terms of network performance - Issue is that to go back to stock firmware is not easy as the others - Advantage is that its a lot harder to brick.

K.

EDIT : Deleted my comment as was meant to be a private message.

2 Likes