DLink DIR 600 - stuck

Hi! :slight_smile:
I have a DIR 600 B6 model. Before OpenWRT there was 2.18 firmware in it. Yesterday tried to install OpenWRT for the first time, downloaded the image, followed instructions and booted Emergency web interface. The image was successfully uploaded, countdown finished but nothing happened with the router, no reboot, no other lights other then blinking power and port light.
Unplugging doesn't help, it always boots straight to Emergency mode. Tried flashing original firmware back, but stays the same. Is it bricked or what?

Thans in advance.

Johnny

  • What version of OpenWrt did you flash?
  • And to be clear, which file did you use?

Thank you for the reply. :slight_smile:

From here downloaded Firmware OpenWrt Install version 18.06.1 for B6, B6E:

https://openwrt.org/toh/d-link/dir-300revb

Can you try 17.01.4?

Tried it, still the same issue. It uploads the image, then it's seems like nothing is happening. With every image is the same. Tried reseting it and unplugging, but when turned on it just goes straight to Emergency interface. I just don't get it, if it is bricked why is it allowing Emergency interface?

Hi, same issue here. DLink DIR-600 B6/B6E. https://openwrt.org/toh/hwdata/d-link/d-link_dir-600_b6_b6e
Stuck in emergency mode loop.
First time after image pushing leds was blinking for few seconds before behing stable.
Then after that all the times it stuck in emergency mode page. On/off led blinks slowly as when I've pushed reset button for the first time. When uploading an image, the confirmation page shows up, then on/off led and webserver shut down. No blinking as first time that would indicate a memory edition. Only led port indicator is up. When device is re-plugged, it starts itself in emergency mode, with on/off blinking without reset button behing hit.
Tried with in order openwrt-18.06.1-ramips-rt305x-dir-610-a1-squashfs-factory.bin, lede-17.01.4-ramips-rt305x-dir-610-a1-squashfs-factory.bin and lede-17.01.0-r3205-59508e3-ramips-rt305x-dir-610-a1-squashfs-factory.bin image files.
Any help welcome! Sorry for my English.

Hi,
have you solved? I have the same issue!

J.

Hi,

For me, after opening my device and solder the wire to access the console with an usb/rs232 adaptor (following the "Unbrick" procedure here ). I have my DIR-600b6 back with the stock firmware.

But each time I try to put OpenWrt, it works after fresh reboot, but the very next one it's the same issue ( Emergency Web Interface).

Another thing I have noticed, it seems that if the console is connected while booting, sometimes it causes crash, so disconnect the console after flashing the firmware, and watch the leds.

Finally I've followed instructions in this page, then upgrade to the latest possible version (because of memory limitation of the device) of OpenWrt (19.07.8). And it seems to works ! ! ! Even after multiple reboot and switch off/on. Thanks to this guy.