Disabling IPv6

I've tried to disable IPv6 on my Fritzbox 4040, image openwrt-23.05.0-ipq40xx-generic-avm_fritzbox-4040-squashfs-eva, but the IPv6 address still is assigned to the br-lan interface.

In /etc/config/network, in section config interface 'lan', I've removed option ip6assign '60' and added option ipv6 '0'.

In /etc/config/dhcp, in section config dhcp 'lan', I've added option dhcpv6 'disabled' and commented out option ra 'server'.

When I reboot, ifconfig still shows both an IPv4 and an IPv6 address for interface br-lan, and any computer I connect to the lan ports gets assigned both an IPv4 and IPv6 address.

What's going wrong here?

You need to disable automatic lla assignment in Network/Interfaces/Devices to get rid of sla automatic assignment.

This is a list I have found that should disable IPv6:

uci set 'network.lan.ipv6=0'
uci set 'network.wan.ipv6=0'
uci -q delete dhcp.lan.dhcpv6
uci -q delete dhcp.lan.ra
uci set network.lan.delegate="0"
uci -q delete network.globals.ula_prefix
/etc/init.d/odhcpd disable
/etc/init.d/odhcpd stop
uci commit

Reboot afterwards

1 Like

If you prefer LuCI:
You can also set wan6 in interfaces to 'unmanaged' and then disable the interface in the edit. I would not delete it all together.
Then, in devices/eth0 (or whatever your wan port is) scroll to the bottom and disable ipv6 at the bottom of general settings.