Disable RATE_LIMIT in OpenWrt router

So I just installed Pi-Hole on a Raspberry Pi 4B and been getting a RATE_LIMIT error and saying that my router is the culprit! Is there a way I can fix this in my router or is this a Pi issue!? I also disabled the RATE_LIMIT in the Pi-Hole settings but still get this issue.

Router is a GL-iNet GL-MT1300 Beryl with LuCI installed.

there is this?

option dnsforwardmax '150'

but your phrasing does not ring any bells...

This is what I'm referring to... lol

1 Like

appears to be a pi-hole setting / limitation... nothing about that message says

Is there a way to remove the rate limit of the router in Pi-Hole somehow!? and do you know how!? lol

I don't use pihole... lemme search-engine-fu that for you

There is an option in /etc/pihole/pihole-FTL.conf named RATE_LIMIT.

Default is "RATE_LIMIT=1000/60" (1000 queries pro 60 seconds).

I suggest setting it to "RATE_LIMIT=1000/1" (1000 queries pro second) or even "RATE_LIMIT=10000/1". Don't forget to restart pihole after editing pihole-FTL.conf.

Good luck.

Thank you! But is it normal that Pi-Hole doesn't have that in the settings cause I had to add RATE_LIMIT=0/0 myself cause it wasn't listed in that file when I looked into it before and found that!?

Yes, it is normal.

For every option you do not specify there is a default value.

Ok. Yeah it seems to have fixed the issue, I just went with 50.000/1 and just checked it and have 2,135,277+ total queries out of 1,805,399 total adlists!! LOL

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.