Disable ipv6 on the router error


I want disable ipv6, because getting IPv6 from my ISP isn't yet an option.
I don't know anyone who uses an ipv6 address. There is no internet provider in the wide area that provides an ipv6 address.
Millions of customers in the Europe, and they operate IPv4 ONLY...
That's why I want to turn it off.

I know is already discussed but i cannot a solution.

In general one could say that completely disabling IPv6 is not a supported configuration anymore when using prebuilt images. There's various services you can disable and a bunch of sysctls you could tune to disable IPv6 link local addressing on interfaces but there's no high level configuration options for that.

i found this suggestion:

OpenWrt 22.03.2

uci set 'network.lan.ipv6=0'
uci set 'network.wan.ipv6=0'
uci set 'dhcp.lan.dhcpv6=disabled'
/etc/init.d/odhcpd disable
uci commit

uci -q delete dhcp.lan.dhcpv6
uci -q delete dhcp.lan.ra
uci commit dhcp
/etc/init.d/odhcpd restart

uci set network.lan.delegate="0"
uci commit network
/etc/init.d/network restart

/etc/init.d/odhcpd disable
/etc/init.d/odhcpd stop

uci -q delete network.globals.ula_prefix
uci commit network
/etc/init.d/network restart

After I successfully disabled ipv6 i got an kernel error:

[59710.653683] ------------[ cut here ]------------
[59710.658348] WARNING: CPU: 0 PID: 773 at backports-5.15.58-1/net/mac80211/tx.c:944 0x82436fc8 [mac80211@03d4aa8b+0x81240]
[59710.669225] Modules linked in: pppoe ppp_async nft_fib_inet nf_flow_table_ipv6 nf_flow_table_ipv4 nf_flow_table_inet pppox ppp_generic nft_reject_ipv6 nft_reject_ipv4 nft_reject_inet nft_reject nft_redir nft_quota nft_objref nft_numgen nft_nat nft_masq nft_log nft_limit nft_hash nft_flow_offload nft_fib_ipv6 nft_fib_ipv4 nft_fib nft_ct nft_counter nft_chain_nat nf_tables nf_nat nf_flow_table nf_conntrack mt76x2e mt76x2_common mt76x02_lib mt7603e mt76 mac80211 cfg80211 slhc nfnetlink nf_reject_ipv6 nf_reject_ipv4 nf_log_ipv6 nf_log_ipv4 nf_log_common nf_defrag_ipv6 nf_defrag_ipv4 libcrc32c crc_ccitt compat ledtrig_usbport sha256_generic libsha256 seqiv jitterentropy_rng drbg hmac cmac leds_gpio xhci_plat_hcd xhci_pci xhci_mtk xhci_hcd gpio_button_hotplug usbcore nls_base usb_common crc32c_generic
[59710.740931] CPU: 0 PID: 773 Comm: mt76-tx phy0 Tainted: G        W         5.10.146 #0
[59710.748855] Stack : 00000000 8072637c 809b0000 82225228 00000000 00000000 00000000 00000000
[59710.757212]         00000000 00000000 00000000 00000000 00000000 00000001 822b5c18 3f150cff
[59710.765560]         822b5cb0 00000000 00000000 822b5ac0 00000038 80399bc4 ffffffea 00000000
[59710.773903]         822b5acc 0000020b 807ca868 ffffffff 822b5bf8 806f5114 00000000 806f0000
[59710.782251]         00000009 93ad3cc4 82225228 82225228 00000018 80403500 00000000 80990000
[59710.790605]         ...
[59710.793057] Call Trace:
[59710.793111] [<80399bc4>] 0x80399bc4
[59710.799041] [<80403500>] 0x80403500
[59710.802528] [<80007b08>] 0x80007b08
[59710.806001] [<80007b10>] 0x80007b10
[59710.809470] [<8037ecd4>] 0x8037ecd4
[59710.812965] [<82436fc8>] 0x82436fc8 [mac80211@03d4aa8b+0x81240]
[59710.818857] [<8007fb60>] 0x8007fb60
[59710.822343] [<82436fc8>] 0x82436fc8 [mac80211@03d4aa8b+0x81240]
[59710.828237] [<8003007c>] 0x8003007c
[59710.831716] [<82436fc8>] 0x82436fc8 [mac80211@03d4aa8b+0x81240]
[59710.837611] [<80030144>] 0x80030144
[59710.841129] [<82436fc8>] 0x82436fc8 [mac80211@03d4aa8b+0x81240]
[59710.847056] [<824386b0>] 0x824386b0 [mac80211@03d4aa8b+0x81240]
[59710.852996] [<823e7760>] 0x823e7760 [mt76@4ce41ad0+0xafe0]
[59710.858453] [<80060858>] 0x80060858
[59710.861946] [<823e79c0>] 0x823e79c0 [mt76@4ce41ad0+0xafe0]
[59710.867410] [<806d8590>] 0x806d8590
[59710.870895] [<823e0564>] 0x823e0564 [mt76@4ce41ad0+0xafe0]
[59710.876363] [<823e05f4>] 0x823e05f4 [mt76@4ce41ad0+0xafe0]
[59710.881826] [<806d8a1c>] 0x806d8a1c
[59710.885314] [<80050d54>] 0x80050d54
[59710.888787] [<80050c18>] 0x80050c18
[59710.892283] [<80050c18>] 0x80050c18
[59710.895779] [<80050c18>] 0x80050c18
[59710.899253] [<80002f38>] 0x80002f38
[59710.904639] ---[ end trace fbb50a2725260c07 ]---

try restarting the device, instead of restarting the network service.

I tried that, unfortunately the same error appears again immediately after booting...

I downgraded to a lower firmware version. Then I disabled ipv6 again.
bridge: filtering via arp/ip/ip6tables is no longer available by default. Update your scripts to load br_netfilter if you need this.
What does this statement mean? It's dangerous ?