Disable Double NAT

Hey there,

I migrated to OpenWRT 21.02 and thereby wanted to also get ride of my doube NAT setting. I found this Wiki page but failig so far...:

  • I set a route in my FB for my OpenWRT subnet 10.1.2.1/24 to the OpenWRT FB net ip 10.1.1.208
  • I disabled Masquerading and MSS clamping on the WAN interface on OpenWRT.

Now I am struggling to set the static route on OpenWRT to route all internet traffic to the upstream FB on 10.1.1.1.

Thanks a lot.

connect LAN-LAN, disable DHCP, you're set.

IP of openwrt device isn't really relevant,. since it won't be doing any routing.

1 Like

Actually you don't have to do that since its default route to everything outside 10.1.2.0/24 is already the main router 10.1.1.1.

If you want to add a static route explicitly use Network--Static Routes in the GUI or this syntax in /etc/config/network:

config route
    option target '10.1.1.0/24'
    option gateway '10.1.1.1'
1 Like

Just to clarify the situation.

What is usually meant by "disabling double NAT", would be using the ISP device as modem only - and then terminating the PPPoE session on your OpenWrt router. This isn't really possible using recent'ish Fritz!OS versions anymore (well, there is an undocumented/ unsupported trick, but, well…) - and doing so would also make all the non-modem features of your Fritz!Box unusable (phone pbx, ATA, DECT, etc.).

In this situation using an OpenWrt as downstream router, with static routes configured on the Fritz!Box and without masquerading (double NAT) on the OpenWrt router is the next best alternative. Not great (as the proprietary devices needs to be 'good enough' to do handle the PPPoE session and NAT), but the only way to keep the additional (mostly phone-) features working.

1 Like