DIR-810L Flashing

I am trying to install OpenWrt in my DIR-810L rev 1B and I have such a basic question that I don't see the answer anywhere.

I have read a lot but I can't find it.

in the site OpenWrt org/toh/d-link/dir-810l it gives you steps to Flash it but on step 5 it states

Step 5: modify it like so: ./ncc_att_hwid -f /tmp/openwrt-15.05-ramips-mt7620-dir-810l-squashfs-sysupgrade.bin -m DIR-810L -H B1 -r WW -c 1.0 -F 2.03b02 -a

Ok so I have to run that command but where do I put that command? I have read a lot but I can't find any reference to where to run that command.

Any help is appreciated.

It looks like you skipped step one to three then? The command needs to be run inside the exploded archive. You can also just specify the full (absolute) path to ncc_at_hwid.

I am missing something that is at the core of the issue.

Here are the steps I just took this morning as I started from scratch.

  1. Download the SKD
  2. Extracted the .tar
    Here 7zip asked me if I wanted to replace the "existing file"(odd because this is a new path). Yes, no, auto-rename. (I tried all 3 at different times to see if the following step worked any differently)
  3. Found the tool/file ncc_att_hwid in the expected path
  4. Downloaded the sysupgread.bin image
  5. In the command prompt navigated to the path where the tool is and tried the command posted above.

It gives me the error 'ncc_att_hwid' is not recognized as an internal or external command,
operable program or batch file.

There has to be a problem with my process that is at the core of the issue its like I am using the wrong environment or something at the base of all.

Try a chmod +x on the file before you try running it.

I think you inadvertently showed me the problem. This has to be done in Linux like CentOS or Ubuntu. And me here doing it on windows like a zombie...

2 Likes

You need the full path to ncc_att_hwid. For example /usr/home/***/Downloads/......
Secondly, it is a 32bit binary, If you're running a 64bit LInux machine you will need some 32bit libs. I don't do windows so I'm not sure what you would specifically need.

If that does not work post back. I installed to a TEW-810DR using u-boot, usb serial adapter, tftp server and the initramfs image - did not need to append the cameo signature. The Trendnet shares the some board/OpenWrt build as the D-Link DIR-810L so it should work for you.

There are some fixes in the latest kernel 5.4 build (NIC port numbering, and detection of the WAN port) which I'm running on my Trendnet TEW-810DR. I have not tried the recently committed DSA code.

Thanks a lot on the 32 bit suggestion I do have CentOS 64bit so I will just make a vm with a 32 bit version and give it a try.

In Debian 10, when I tried to execute the command, with full path, it prompted for the missing 32 libs.