DIR-600 B2 (Ralink RT3050) won't give IP when used as a wireless repeater with encryption

So, I've been trying to use a D-Link DIR-600 B2 router to use as a wireless repeater bridge using the relayd package ¿this guide?

Following that guide, without adding a WiFi Network, the repeater works:
If I connect a wired device, it gets an IP from the orignal DHCP server.

If I add a WiFi network without encryption/security (an open network) it works:
Wired and wireless devices get an IP from the original DHCP server.

But as soon as I use security in the added Wi-Fi network, I can no longer get an IP nor connect to the internet (using a static IP on a device connected to the repeater).
But if I remove the WiFi network or remove the encryption, it works again.

Wi-Fi without encryption won't work for me.

I already tried 3 versions of OpenWRT firmware (18.06 which did not store configuration between reboots, 17.01 and 19.07 with ppp and opkg removed) with the same result.

I don't think it's a configuration issue since when using an open WiFi network, the bridge is working correctly, so I'm guessing I'm missing something somewhere.

Any ideas other than toss the device and buy a new one (not an option for now).