DIR-2660 new install has SSH but no luci

First off I'm super excited that OpenWrt is now available for the D-Link DIR-2660 A1. I've literally been refreshing the git page most every day since I got the thing and realized there was no way I could stand to use the stock firmware.

Anyway... I've downloaded the latest .bin and pushed it to the router only to find that I can't http:// to it as nothing seems to be listening to port 80 (luci isn't running?).

I can however ssh to the device and look around just fine.

Is there something I'm missing or is the build maybe just not quite ready for prime time yet?

I've tried running firstboot and that didn't help.

1 Like
netstat -l -n -p | grep  -e uhttpd; pgrep -f -a uhttpd

https://openwrt.org/docs/guide-user/luci/luci.essentials#basic_installation

2 Likes

You have installed a master snapshot, which doesn't include luci by default (but you can install it over ssh, see the wiki for details).

3 Likes

Hi livebythecode, have have you gotten so far? I'm going to be a first-time WRT user, got the same router as yours. One major reason why I want to try it out is I need to try and see if I can get channels about 100 on the device.

If you're inquiring as to whether the DIR-2660 will work with LuCi,
It should, since it definitely works with DIR-878 and DIR-882.

OpenWrt D-Link DIR-882 A1:

D-Link DIR-1760 A1, D-Link DIR-1960 A1 and D-Link DIR-2660 A1 also are very similar to this router, but they have more RAM (256 MB) and flash (128 MB NAND).

1 Like

Hi All -

for the life of me I cannot get the OpenWRT to connect to internet to install LuCI.

My Conf;
Internet (VM modem in Bridge mode) -> pfSense (192.168.1.1) -> OpenWRT Router

My Qn;
I can SSH into the OWRT router, below URL to connect to my gateway (pfSense), but it is not working.


How do I check if the router is connected to my gateway?

thanks for any help...

First guess is that you have the same 192.168.1.x subnet in the OpenWrt rtouer on both LAN side and WAN side (pfSense's network). You need to change the LAN subnet to 192.168.2.x or something like that, so the the OpenWrt router can router properly.

3 Likes

... or if you want to use the router as an AP, connect it through the LAN port, set a static IP (preferred), and disable the DHCP.

1 Like

You are right hnyman, would changing the IP be enough (uci set network.lan.ipaddr="192.168.2.1"), Apologies but I am a beginner and setup pfSense only a few days back. Then connect the output of pfSense into the WAN port if the OWRT router?

Yes. and "uci commit".
(or just edit /etc/config/network by hand)

then reboot the router.

And remember that the router is then accessed via 192.168.2.1 :wink:

3 Likes

thank you very much, and it worked..!!!!

Mark the thread as solved.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.