DIR-2640, no 2.4Ghz radio

First post, and first time OpenWrt user!

Installed OpenWrt on a D-Link DIR-2640, and got the 5Ghz, LAN & WAN working. However, I only see a single radio in the Wireless page (radio0), and no 2.4Ghz option anywhere. Spec sheet says this rooter has two radios.

Can anyone confirm that radio1/2.4Ghz can be activated on this router with OpenWrt 23.05.3? And if so, how?

My OpenWrt knowledge is very limited, and my linux incantation level is -11.

But you can SSH into your router, right?

Post the output of these commands using the "Preformatted text </> " button:

ubus call system board
cat /etc/config/wireless

Remember to redact passwords, MAC addresses and any public IP addresses you may have.

Does it help sysupgrading to latest sysupgrade image resetting settings
https://firmware-selector.openwrt.org/?version=23.05.3&target=ramips%2Fmt7621&id=dlink_dir-2640-a1

If your DIR-2640 is rev.A1,
I did install 23.05.3 in a DIR-878 and DIR-882; both of which share same design as DIR-2640. The 2.4 GHz settings were in the same page as the 5 GHz.

With that said,
Was not happy with the performance, so switched to OpenWRT snapshot release recently avoiding the Firmware selector feature.

Yep, I can SSH into the router, but haven't much idea of what I'm doing in there.
Here's the outputs :

root@OpenWrt:~# ubus call system board
{
        "kernel": "5.15.150",
        "hostname": "OpenWrt",
        "system": "MediaTek MT7621 ver:1 eco:3",
        "model": "D-Link DIR-2640 A1",
        "board_name": "dlink,dir-2640-a1",
        "rootfs_type": "squashfs",
        "release": {
                "distribution": "OpenWrt",
                "version": "23.05.3",
                "revision": "r23809-234f1a2efa",
                "target": "ramips/mt7621",
                "description": "OpenWrt 23.05.3 r23809-234f1a2efa"
        }
}
root@OpenWrt:~# cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option path '1e140000.pcie/pci0000:00/0000:00:01.0/0000:01:00.0'
        option channel 'auto'
        option band '5g'
        option htmode 'VHT80'
        option country 'CA'
        option cell_density '0'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'SUPERSEKRITSSID'
        option encryption 'psk2'
        option key 'SUPERSEKRITPWD-redacted-tho'
        option wpa_disable_eapol_key_retries '1'

config wifi-iface 'wifinet1'
        option device 'radio0'
        option mode 'ap'
        option ssid 'OpenWrt'
        option encryption 'none'
        option disabled '1'

@Warlock : yes, it's the DIR-2640 rev A1.
Perfomance is fine so far, we only have a 150/30 connexion - this is a cottage in the country. Having only 5Ghz is not a real issue so far, was wanting the 2.4Ghz for more range and legacy devices, when/if I bring them over.

@brada4 : have not tried re-flashing the image, but my current one is same revision as the latest (OpenWrt 23.05.3 r23809-234f1a2efa)

I think the main point of sysupgrade was resetting the settings.

You might try resetting your configuration using
firstboot -y && reboot

It should have the same effect.
You can backup your config beforehand, just in case.

After you've done it maybe post the system log here, if the 2.4 wifi still doesn't show up.

1 Like

Will a firsboot -y && reboot also reset the wifi? I.e : will the wifi still be up after said reset? Because the only laptop I have here has no ethernet port, so if I have the physically connect via ethernet, I'd be out cold...

Correct. WiFi will not be functioning.
Reference: Your device's settings will be reset to defaults like when OpenWrt was first installed.

Suggest you wait until you have access to network cable.

2 Likes

Yes, maybe get a USB LAN adapter, before trying to fix your WiFi.

1 Like

Since you already have installed OpenWRT firmware in your DIR-2640;
If you intend to re-flash firmware via D-Link recovery method,
Reminder to use dlink_dir-2640-a1-squashfs-recovery.bin files.

1 Like

@Warlock @dnd

I'll bring the router back to the city tomorrow; if I mess it up, I'll still have internet access and ethernet ports to fix it instead of being dead in the water.
Seing I already have the latest firmware, I don't think I'll reflash just yet.

2 Likes