Difficulties setting up a TP-Link Archer C7 (AC1750) router with dumb AP method to use as a switch/DNS cache

My current OpenWrt setup partly works but with issues
My main goal was to use the extra LAN ports to connect various devices to and also as an Unbound DNS cache (I don't want to use wifi on it)
The OpenWrt router would obviously sit behind the ISP router

The router is a TP-Link Archer C7 v4 (AC1750)
The device I'm editing in LuCI is br-lan (bridged LAN)
The ISP router's IP address is 192.168.0.1
OpenWrt 23.05

  1. I want to be able to access LuCI but I can't connect to it after following the steps in the "dumb AP" guide.

  2. I can't run opkg to install unbound because I'm getting the "operation not permitted" error (I want to run unbound on it to use the OpenWrt router as a basic DNS cache). I did have opkg on a previous setup so this may be fixable somehow.

  3. The steps I have run in the dumb AP guide are as follows

    • I change the IP in Network - Interfaces - edit LAN from 192.168.1.1 to 192.168.1.2 then apply/restart
    • I set the gateway to the ISP router 192.168.0.1 - up to this point it's fine and I can connect to LuCI through the router
    • I set the custom DNS to the ISP router 192.168.0.1 - now I suddenly lose the ability to get back into LuCI through my browser at 192.168.1.2

If you have configured your device as dumb-AP, it needs to be within the same subnet as your ISP router, so 192.168.0.x and not 192.168.1.x (ignore the WAN port for now/ don't connect- or use it; lan ports only).

1 Like

I just want to check I'm doing this right:

I set the IP address of the device to 192.168.0.x to be on the same subnet as ISP router - that's fine.
Do I also leave the gateway and DNS on 192.168.0.1?

I just tried setting the device's IP to 192.168.0.4 and then applying but it timed out and asked if I want to revert settings. Not sure if that implies it definitely doesn't work because the router may be slow in applying settings or something.

Edit: should I also do the rest of the dumb-AP guide, like disabling DHCP and the DHCP services in order to get this working, like could that be why it's timing out without applying the IP?

Edit 2: it appears to be working now, I did all of that.
I still can't get opkg to retrieve the package list though :frowning:

I know everyone has seen the following opkg errors before, but please, if anyone knows what else is causing this after I have followed the dumb-AP guide (and it is mostly working now) please help me out:

Failed to send request: Operation not permitted
Failed to send request: Operation not permitted
Failed to send request: Operation not permitted
Failed to send request: Operation not permitted
Failed to send request: Operation not permitted
Failed to send request: Operation not permitted
Collected errors:
 * opkg_download: Failed to download https://downloads.openwrt.org/releases/23.05.0/targets/ath79/generic/packages/Packages.gz, wget returned 4.
 * opkg_download: Check your network settings and connectivity.

 * opkg_download: Failed to download https://downloads.openwrt.org/releases/23.05.0/packages/mips_24kc/base/Packages.gz, wget returned 4.
 * opkg_download: Check your network settings and connectivity.

 * opkg_download: Failed to download https://downloads.openwrt.org/releases/23.05.0/packages/mips_24kc/luci/Packages.gz, wget returned 4.
 * opkg_download: Check your network settings and connectivity.

 * opkg_download: Failed to download https://downloads.openwrt.org/releases/23.05.0/packages/mips_24kc/packages/Packages.gz, wget returned 4.
 * opkg_download: Check your network settings and connectivity.

 * opkg_download: Failed to download https://downloads.openwrt.org/releases/23.05.0/packages/mips_24kc/routing/Packages.gz, wget returned 4.
 * opkg_download: Check your network settings and connectivity.

 * opkg_download: Failed to download https://downloads.openwrt.org/releases/23.05.0/packages/mips_24kc/telephony/Packages.gz, wget returned 4.
 * opkg_download: Check your network settings and connectivity.

Edit 3: In trying to resolve the opkg, I'm trying to ping from the router, it appears I can ping 8.8.8.8 but not google.com so it seems to be a DNS issue.

Edit 4: I added 8.8.8.8 as a secondary DNS and it actually fixed it, but I don't understand why :slight_smile:
Why wouldn't the ISP router just work as a DNS? Or is the idea of having the ISP router IP set as the DNS just wrong?

dnsmasq/ odhcp must be disabled on the AP, the dumb-AP guide should advise you accordingly.

gateway and DNS server adresses need to be configured to point to your ISP router.

Ping gateway, ping 8.8.8.8, if you are getting response then check your local dns.
If you cannot reach 8.8.8.8 then you are misaingbthe route to 0.0.0.0/0.
I would recommand using a reliable public resolver lite google.
Check like this: nslookup openwrt.org 8.8.8.8
The you can temporary set the 8.8.8.8 as system wide resolver.
echo "nameserver 8.8.8.8" > /etc/resolv.conf