Difference between igmp_snooping on switch and interface section

I did just one more test: I let my iptv box running and made a tcpdump on the entire eth1 interface. I see there IGMP packets. I did the same for the entire eth0 interface and couldn't get a single packet within 5 minutes while the iptv box was running.
Then I enabled in the switch config igmp_snooping for eth1. The subscribed iptv stream began to stutter and hanging for several seconds, I could still see some IGMP packets on eth1 interface. I think this happens because I didn't reboot the iptv box. But then I made a tcpdump on eth0 and now with igmp_snooping enabled on eth1 I also see packets on eth0? This is the same behaviour like described here:

Now the obvious question: I thought this bug is already fixed in the latest build? How would my network config look like if I want to invert the CPU ports for eth0 and eth1?

My current network config (igmp_snooping on switch disabled) looks like this:

root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdbc:33fb:8f21::/48'

config interface 'lan'
        option type 'bridge'
        option igmp_snooping '1'
        option ifname 'eth1.1'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option ifname 'eth0.7'
        option proto 'pppoe'
        option password '[...]'
        option username '[...]'
        option ipv6 'auto'

config interface 'wan6'
        option ifname 'eth0.7'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'
        option igmp_snooping '0'
        option igmp_v3 '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option vid '1'
        option ports '1 2 3 4 5 6t'

config switch_vlan
        option device 'switch0'
        option vlan '7'
        option vid '7'
        option ports '0t 5t'

config interface 'wg0'
        option proto 'wireguard'
        option private_key '[...]'
        option listen_port '[...]'
        list addresses '10.14.0.1/24'

config wireguard_wg0
        option public_key '[...]'
        option persistent_keepalive '25'
        option description '[...]'
        list allowed_ips '10.14.0.3/32'

config wireguard_wg0
        option public_key '[...]'
        option persistent_keepalive '25'
        option description '[...]'
        list allowed_ips '10.14.0.4/32'

config route
        option interface 'wg0'
        option target '10.14.0.0'
        option netmask '255.255.0.0'

root@OpenWrt:~#

Would the config with the inverted CPU ports for eth0 and eth1 (and enabled igmp_snooping) looks like this?

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdbc:33fb:8f21::/48'

config interface 'lan'
        option type 'bridge'
        option igmp_snooping '1'
        option ifname 'eth0.1'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option ifname 'eth1.7'
        option proto 'pppoe'
        option password '[...]'
        option username '[...]'
        option ipv6 'auto'

config interface 'wan6'
        option ifname 'eth1.7'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'
        option igmp_snooping '1'
        option igmp_v3 '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option vid '1'
        option ports '0t 1 2 3 4 5'

config switch_vlan
        option device 'switch0'
        option vlan '7'
        option vid '7'
        option ports '5t 6t'

config interface 'wg0'
        option proto 'wireguard'
        option private_key '[...]'
        option listen_port '[...]'
        list addresses '10.14.0.1/24'

config wireguard_wg0
        option public_key '[...]'
        option persistent_keepalive '25'
        option description '[...]'
        list allowed_ips '10.14.0.3/32'

config wireguard_wg0
        option public_key '[...]'
        option persistent_keepalive '25'
        option description '[...]'
        list allowed_ips '10.14.0.4/32'

config route
        option interface 'wg0'
        option target '10.14.0.0'
        option netmask '255.255.0.0'

Thanks in advance!