Diagnose VDSL connection to Fritzbox 7360

As I ask upon superuser I have a Fritzbox 7360 v2 and I have installed the following version of OpenWRT:

NAME="OpenWrt"
VERSION="SNAPSHOT"
ID="openwrt"
ID_LIKE="lede openwrt"
PRETTY_NAME="OpenWrt SNAPSHOT"
VERSION_ID="snapshot"
HOME_URL="https://openwrt.org/"
BUG_URL="https://bugs.openwrt.org/"
SUPPORT_URL="https://forum.openwrt.org/"
BUILD_ID="r17237-7c4d79aa1c"
OPENWRT_BOARD="lantiq/xrx200"
OPENWRT_ARCH="mips_24kc"
OPENWRT_TAINTS=""
OPENWRT_DEVICE_MANUFACTURER="OpenWrt"
OPENWRT_DEVICE_MANUFACTURER_URL="https://openwrt.org/"
OPENWRT_DEVICE_PRODUCT="Generic"
OPENWRT_DEVICE_REVISION="v0"
OPENWRT_RELEASE="OpenWrt SNAPSHOT r17237-7c4d79aa1c"

And I have configured the following settiongs for a Vodafone Greece VDSL connection:

config interface 'loopback'
    option device 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config globals 'globals'
    option ula_prefix 'fdd2:a40d:d919::/48'

config atm-bridge 'atm'
    option vpi '1'
    option vci '32'
    option encaps 'llc'
    option payload 'bridged'
    option nameprefix 'dsl'

config dsl 'dsl'
        option annex 'b'
    option ds_snr_offset '0'
        option line_mode 'vdsl'
        option tone 'auto'

config device
    option name 'br-lan'
    option type 'bridge'
    list ports 'lan1'
    list ports 'lan2'
    list ports 'lan3'
    list ports 'lan4'

config interface 'lan'
    option device 'br-lan'
    option proto 'static'
    option ipaddr '192.168.1.1'
    option netmask '255.255.255.0'
    option ip6assign '60'

config interface 'wan'
    option ifname 'dsl0.835'
        option device 'dsl0'
    option proto 'pppoe'
    option username '^censored^'
    option password '^censored^'
        option ipv6 'auto'

config interface 'wan6'
    option device '@wan'
    option proto 'dhcpv6'

And I've attempted the connection via:

ifup wan

But a ping into google's DNS fails to be resolved:

PING 8.8.8.8 (8.8.8.8): 56 data bytes
ping: sendto: Network unreachable

How I can log connection info regarding this?
I want to diagnose why I am unable to connect.

First thing, edit /etc/ppp/options to include debug without a commenting #
Then logread | grep ppp wil show you more information about your pppoe connection attempts. You can also give a path for a logfile like logfile /srv/pppd_logs/ppp.log just make sure the directory exists and ideally is on a usb harddisk or usbstick to save your router's NOR/NAND memory.

The outcome of that exercise however is most likely a timeout waiting for PADO packets which is the generic PPPoE negotioation did not succed at all becsuse the remote side never replies. This error is quite unspecific and can be caused by e.g. the dsl cable not being connected, or the wrong VLAN, or ...

I would suggest checking the VDSL link status first:

/etc/init.d/dsl_control dslstat
1 Like

I'm certainly no expert, far from it in fact, but for a VDSL connection, shouldn't the dsl section include a

option xfer_mode 'ptm'

to specify packet transfer mode?

And I think the atm-bridge bit isn't needed.

Unless your ISP really does use ATM over VDSL which I think would be quite unusual as it would be rather inefficient.

Ι did that and I found out that ppp fails:

Fri Jul 30 14:03:42 2021 daemon.err insmod: module is already loaded - ppp_generic
Fri Jul 30 14:03:42 2021 daemon.err insmod: module is already loaded - pppox
Fri Jul 30 14:03:42 2021 daemon.err insmod: module is already loaded - pppoe
Fri Jul 30 14:03:42 2021 daemon.info pppd[3048]: Plugin pppoe.so loaded.
Fri Jul 30 14:03:42 2021 daemon.info pppd[3048]: PPPoE plugin from pppd 2.4.9
Fri Jul 30 14:03:42 2021 daemon.notice pppd[3048]: pppd 2.4.9 started by root, uid 0
Fri Jul 30 14:03:42 2021 daemon.debug pppd[3048]: Send PPPOE Discovery V1T1 PADI session 0x0 length 12
Fri Jul 30 14:03:42 2021 daemon.debug pppd[3048]:  dst ff:ff:ff:ff:ff:ff  src 00:20:da:86:23:75
Fri Jul 30 14:03:42 2021 daemon.debug pppd[3048]:  [service-name] [host-uniq  00 00 0b e8]
Fri Jul 30 14:03:47 2021 daemon.debug pppd[3048]: Send PPPOE Discovery V1T1 PADI session 0x0 length 12
Fri Jul 30 14:03:47 2021 daemon.debug pppd[3048]:  dst ff:ff:ff:ff:ff:ff  src 00:20:da:86:23:75
Fri Jul 30 14:03:47 2021 daemon.debug pppd[3048]:  [service-name] [host-uniq  00 00 0b e8]
Fri Jul 30 14:03:52 2021 daemon.debug pppd[3048]: Send PPPOE Discovery V1T1 PADI session 0x0 length 12
Fri Jul 30 14:03:52 2021 daemon.debug pppd[3048]:  dst ff:ff:ff:ff:ff:ff  src 00:20:da:86:23:75
Fri Jul 30 14:03:52 2021 daemon.debug pppd[3048]:  [service-name] [host-uniq  00 00 0b e8]
Fri Jul 30 14:03:57 2021 daemon.warn pppd[3048]: Timeout waiting for PADO packets
Fri Jul 30 14:03:57 2021 daemon.err pppd[3048]: Unable to complete PPPoE Discovery
Fri Jul 30 14:03:57 2021 daemon.info pppd[3048]: Exit.
Fri Jul 30 14:03:58 2021 daemon.err insmod: module is already loaded - ppp_generic
Fri Jul 30 14:03:58 2021 daemon.err insmod: module is already loaded - pppox
Fri Jul 30 14:03:58 2021 daemon.err insmod: module is already loaded - pppoe
Fri Jul 30 14:03:58 2021 daemon.info pppd[3147]: Plugin pppoe.so loaded.
Fri Jul 30 14:03:58 2021 daemon.info pppd[3147]: PPPoE plugin from pppd 2.4.9
Fri Jul 30 14:03:58 2021 daemon.notice pppd[3147]: pppd 2.4.9 started by root, uid 0
Fri Jul 30 14:03:58 2021 daemon.debug pppd[3147]: Send PPPOE Discovery V1T1 PADI session 0x0 length 12
Fri Jul 30 14:03:58 2021 daemon.debug pppd[3147]:  dst ff:ff:ff:ff:ff:ff  src 00:20:da:86:23:75
Fri Jul 30 14:03:58 2021 daemon.debug pppd[3147]:  [service-name] [host-uniq  00 00 0c 4b]
Fri Jul 30 14:04:03 2021 daemon.debug pppd[3147]: Send PPPOE Discovery V1T1 PADI session 0x0 length 12
Fri Jul 30 14:04:03 2021 daemon.debug pppd[3147]:  dst ff:ff:ff:ff:ff:ff  src 00:20:da:86:23:75
Fri Jul 30 14:04:03 2021 daemon.debug pppd[3147]:  [service-name] [host-uniq  00 00 0c 4b]
Fri Jul 30 14:04:08 2021 daemon.debug pppd[3147]: Send PPPOE Discovery V1T1 PADI session 0x0 length 12
Fri Jul 30 14:04:08 2021 daemon.debug pppd[3147]:  dst ff:ff:ff:ff:ff:ff  src 00:20:da:86:23:75

Also, /etc/init.d/dsl_control dslstat shows:

{
	"api_version": "4.17.18.6",
	"firmware_version": "5.7.9.9.0.6",
	"chipset": "Lantiq-VRX200",
	"driver_version": "1.5.17.6",
	"state": "Showtime with TC-Layer sync",
	"state_num": 7,
	"up": true,
	"uptime": 281,
	"atu_c": {
		"vendor_id": [
			181,
			0,
			66,
			68,
			67,
			77,
			208,
			8
		],
		"vendor": "Broadcom 208.8",
		"system_vendor_id": [
			181,
			0,
			66,
			68,
			67,
			77,
			0,
			0
		],
		"system_vendor": "Broadcom",
		"version": [
			50,
			48,
			46,
			48,
			46,
			55,
			46,
			49,
			32,
			86,
			69,
			95,
			49,
			51,
			95,
			48
		],
		"serial": [
			65,
			65,
			49,
			55,
			51,
			50,
			70,
			83,
			50,
			71,
			66,
			45,
			50,
			49,
			0,
			0,
			0,
			0,
			0,
			0,
			0,
			0,
			0,
			0,
			0,
			0,
			0,
			0,
			0,
			0,
			0,
			0
		]
	},
	"power_state": "L0 - Synchronized",
	"power_state_num": 0,
	"xtse": [
		0,
		0,
		0,
		0,
		0,
		0,
		0,
		2
	],
	"annex": "B",
	"standard": "G.993.2",
	"profile": "17a",
	"mode": "G.993.2 (VDSL2, Profile 17a)",
	"upstream": {
		"vector": false,
		"trellis": true,
		"bitswap": true,
		"retx": false,
		"virtual_noise": false,
		"interleave_delay": 6000,
		"data_rate": 253000,
		"latn": 16.600000,
		"satn": 16.600000,
		"snr": 6.000000,
		"actps": -90.100000,
		"actatp": 10.300000,
		"attndr": 253000
	},
	"downstream": {
		"vector": false,
		"trellis": true,
		"bitswap": true,
		"retx": true,
		"virtual_noise": false,
		"interleave_delay": 890,
		"data_rate": 15740000,
		"latn": 12.600000,
		"satn": 12.600000,
		"snr": 6.000000,
		"actps": -90.100000,
		"actatp": 11.100000,
		"attndr": 15740848
	},
	"errors": {
		"near": {
			"es": 12,
			"ses": 5,
			"loss": 0,
			"uas": 38787425,
			"lofs": 0,
			"fecs": 0,
			"hec": 0,
			"ibe": 0,
			"crc_p": 0,
			"crcp_p": 0,
			"cv_p": 0,
			"cvp_p": 0,
			"rx_corrupted": 753,
			"rx_uncorrected_protected": 325,
			"rx_retransmitted": 0,
			"rx_corrected": 428,
			"tx_retransmitted": 0
		},
		"far": {
			"es": 7215,
			"ses": 3770,
			"loss": 0,
			"uas": 38787425,
			"lofs": 0,
			"fecs": 14911,
			"hec": 0,
			"ibe": 0,
			"crc_p": 0,
			"crcp_p": 0,
			"cv_p": 0,
			"cvp_p": 0
		}
	}
}

Therefore, for some reason VDSL seems to be recognized but fails to perform a PPP call.

There should be either option ifname (old style) or option device (new style), but not both.
Assuming your ISP requires VLAN tag 835, please try this instead:

config interface 'wan'
    option device 'dsl0.835'
    ...
1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.