I’m having a similar issue to one others have posted in the forum. Thank you for any insight you can offer!
TLDR:
Netgear router running Netgear’s Firmware gets IPv6 through DHCPv6 from ISP
Same device running OpenWRT can’t get an IPv6 from ISP
System log shows:
daemon.err odhcp6c[1955]: Failed to send RS (Address not available)
ISP = EPB Fiber (Chattanooga, TN, USA)
Troubleshooting steps taken:
-
Verified ISP is providing IPv6 addresses through:
-a live boot Linux Mint laptop plugged directly into fiber box
-Netgear WNDR4500v3 running NetGenie 1.0.58 -
Verified IPv6 is enabled: sysctl net.ipv6.conf.eth0.2 shows net.ipv6.conf.eth0/2.disable_ipv6 = 0
-
Power cycling the router
-
Stopped and restarted the WAN6 interface
-
Disabling wan6 start on boot and manually starting did not retrieve an IPv6 address
-
enabling/disabling the ‘force link’ options
-
verified the DHCPv6 protocol is open through the firewall (using the default install rules)
Posts suggestions tried:
- Restart WLAN IPV6 Interface after Boot to get DHCP IP
- https://tomthorogood.net/writing/openwrt-disabled-ipv6/
- https://github.com/openwrt/openwrt/issues/13611
- Daemon.err odhcp6c[3966]: Failed to send SOLICIT message to ff02::1:2 (Address not available)
Config & Logs
Linux version 5.15.167 (builder@buildhost) (mips-openwrt-linux-musl-gcc (OpenWrt GCC 12.3.0 r24106-10cc5fcd00) 12.3.0, GNU ld (GNU Binutils) 2.40.0) #0 Mon Sep 23 12:34:46 2024
network config
config interface 'loopback' option device 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config globals 'globals' option ula_prefix 'fd71:e43d:2f9d::/48'
config device option name 'br-lan'
option type 'bridge'
list ports 'eth0.1'
config interface 'lan' option device 'br-lan'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
option ip6assign '60'
config device option name 'eth0.2'
option macaddr ‘a1:b2:c3:d4:e5:ad'
config interface 'wan' option device 'eth0.2'
option proto 'dhcp'
config interface 'wan6' option device 'eth0.2'
option proto 'dhcpv6'
option reqaddress 'force'
option reqprefix 'auto'
option force_link '1'
System and Kernel Logs After Physical power cycle of device:
Kernel log:
[ 10.568727] Atheros AR8216/AR8236/AR8316 mdio.0:00: Port 5 is up [ 10.576495] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[ 10.584811] eth0: link up (1000Mbps/Full duplex)
[ 10.594868] IPv6: ADDRCONF(NETDEV_CHANGE): eth0.1: link becomes ready
...
[ 38.213695] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[ 38.220590] eth0: link up (1000Mbps/Full duplex)
[ 38.239349] br-lan: port 1(eth0.1) entered blocking state
[ 38.244948] br-lan: port 1(eth0.1) entered disabled state
[ 38.250860] device eth0.1 entered promiscuous mode
[ 38.255824] device eth0 entered promiscuous mode
[ 38.286062] br-lan: port 1(eth0.1) entered blocking state
[ 38.291710] br-lan: port 1(eth0.1) entered forwarding state
[ 39.218944] IPv6: ADDRCONF(NETDEV_CHANGE): br-lan: link becomes ready
[ 98.579150] Atheros AR8216/AR8236/AR8316 mdio.0:00: Port 2 is up
System log:
Mon Feb 3 19:24:13 2025 daemon.notice netifd: VLAN 'eth0.2' link is up Mon Feb 3 19:24:13 2025 daemon.notice netifd: Interface 'wan' has link connectivity
Mon Feb 3 19:24:13 2025 daemon.notice netifd: Interface 'wan' is setting up now
Mon Feb 3 19:24:13 2025 daemon.notice netifd: Interface 'wan6' has link connectivity
Mon Feb 3 19:24:13 2025 daemon.notice netifd: wan (1953): udhcpc: started, v1.36.1
Mon Feb 3 19:24:14 2025 kern.info kernel: [ 39.218944] IPv6: ADDRCONF(NETDEV_CHANGE): br-lan: link becomes ready
**Mon Feb 3 19:24:14 2025 daemon.err odhcp6c[1951]: Failed to send RS (Address not available)**
Mon Feb 3 19:24:15 2025 user.notice firewall: Reloading firewall due to ifup of lan (br-lan)
Mon Feb 3 19:24:15 2025 daemon.info procd: - init complete -
Mon Feb 3 19:24:16 2025 daemon.notice netifd: wan (1953): udhcpc: broadcasting discover
Mon Feb 3 19:24:16 2025 daemon.notice netifd: wan (1953): udhcpc: broadcasting select for 100.68.*redacted*, server 184.*redacted*
Mon Feb 3 19:24:16 2025 daemon.notice netifd: wan (1953): udhcpc: lease of 100.68.*redacted* obtained from 184.*redacted* , lease time 86400
Mon Feb 3 19:24:16 2025 daemon.notice netifd: Interface 'wan' is now up