So this is my /etc/config/network:
config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config globals 'globals'
option ula_prefix 'fd46:ed01:2a30::/48'
config interface 'lan'
option type 'bridge'
option ifname 'eth1.1'
option proto 'static'
option netmask '255.255.255.0'
option ip6assign '60'
option ipaddr '192.168.2.1'
config interface 'wan'
option ifname 'eth0.2'
option proto 'dhcp'
config interface 'wan6'
option ifname 'eth0.2'
option proto 'dhcpv6'
option reqaddress 'try'
option reqprefix 'auto'
config switch
option name 'switch0'
option reset '1'
option enable_vlan '1'
config switch_vlan
option device 'switch0'
option vlan '1'
option ports '1 2 3 4 0t'
config switch_vlan
option device 'switch0'
option vlan '2'
option ports '5 6t'
config interface 'relay_bridge'
option proto 'relay'
list network 'lan'
list network 'wan'
option ipaddr '192.168.178.2'
option force_link '1'
config interface 'relay6_master'
option ifname 'eth0.2'
option proto 'static'
option netmask '255.255.255.0'
option ipaddr '192.168.2.1'
option force_link '0'
and my /etc/config/dhcp:
config dnsmasq
option domainneeded '1'
option localise_queries '1'
option rebind_protection '1'
option rebind_localhost '1'
option local '/lan/'
option domain 'lan'
option expandhosts '1'
option readethers '1'
option leasefile '/tmp/dhcp.leases'
option resolvfile '/tmp/resolv.conf.auto'
option localservice '1'
config dhcp 'lan'
option interface 'lan'
option ignore '1'
option ra 'relay'
option dhcpv6 'relay'
option ndp 'hybrid' # Also tried relay here
config dhcp 'wan'
option interface 'wan'
option ignore '1'
config odhcpd 'odhcpd'
option maindhcp '0'
option leasefile '/tmp/hosts/odhcpd'
option leasetrigger '/usr/sbin/odhcpd-update'
option loglevel '4'
config dhcp 'wan6'
option interface 'wan6'
option ignore '1'
config dhcp 'relay6_master'
option interface 'relay6_master'
option ra 'relay'
option ndp 'relay'
option dhcpv6 'relay'
option master '1'
option ignore '1'
Clients get IPv6 adresses correctly, the default route also seems to be valid:
C:\Users\V10lator>ipconfig
Windows-IP-Konfiguration
Ethernet-Adapter Ethernet:
Verbindungsspezifisches DNS-Suffix: fritz.box
IPv6-Adresse. . . . . . . . . . . : 2001:a61:347e:901:dc88:af04:6e33:3b45
IPv6-Adresse. . . . . . . . . . . : fd00::dc88:af04:6e33:3b45
IPv6-Adresse. . . . . . . . . . . : fd46:ed01:2a30::507
IPv6-Adresse. . . . . . . . . . . : fdf8:b879:e2a8::507
Temporäre IPv6-Adresse. . . . . . : 2001:a61:347e:901:b172:4133:eec2:221f
Temporäre IPv6-Adresse. . . . . . : fd00::b172:4133:eec2:221f
Verbindungslokale IPv6-Adresse . : fe80::dc88:af04:6e33:3b45%14
IPv4-Adresse . . . . . . . . . . : 192.168.178.42
Subnetzmaske . . . . . . . . . . : 255.255.255.0
Standardgateway . . . . . . . . . : fe80::1aa6:f7ff:feeb:6624%14
192.168.178.1
C:\Users\V10lator>ping fe80::1aa6:f7ff:feeb:6624%14
Ping wird ausgeführt für fe80::1aa6:f7ff:feeb:6624%14 mit 32 Bytes Daten:
Antwort von fe80::1aa6:f7ff:feeb:6624%14: Zeit=2ms
Antwort von fe80::1aa6:f7ff:feeb:6624%14: Zeit=1ms
Antwort von fe80::1aa6:f7ff:feeb:6624%14: Zeit=1ms
Antwort von fe80::1aa6:f7ff:feeb:6624%14: Zeit=1ms
Ping-Statistik für fe80::1aa6:f7ff:feeb:6624%14:
Pakete: Gesendet = 4, Empfangen = 4, Verloren = 0
(0% Verlust),
Ca. Zeitangaben in Millisek.:
Minimum = 1ms, Maximum = 2ms, Mittelwert = 1ms
but I can't reach any global address:
C:\Users\V10lator>ping -6 google.de
Ping wird ausgeführt für google.de [2001:4860:4802:36::75] mit 32 Bytes Daten:
Zielnetz nicht erreichbar.
Zielnetz nicht erreichbar.
Zielnetz nicht erreichbar.
Zielnetz nicht erreichbar.
Ping-Statistik für 2001:4860:4802:36::75:
Pakete: Gesendet = 4, Empfangen = 0, Verloren = 4
(100% Verlust),
The OpenWRT router itself has perfect IPv6 connectivity:
C:\Users\V10lator>ssh root@192.168.178.2
root@192.168.178.2's password:
BusyBox v1.30.1 () built-in shell (ash)
_______ ________ __
| |.-----.-----.-----.| | | |.----.| |_
| - || _ | -__| || | | || _|| _|
|_______|| __|_____|__|__||________||__| |____|
|__| W I R E L E S S F R E E D O M
-----------------------------------------------------
OpenWrt 19.07.2, r10947-65030d81f3
-----------------------------------------------------
root@OpenWrt:~# ping6 google.de
PING google.de (2001:4860:4802:36::75): 56 data bytes
64 bytes from 2001:4860:4802:36::75: seq=0 ttl=57 time=7.897 ms
64 bytes from 2001:4860:4802:36::75: seq=1 ttl=57 time=6.270 ms
64 bytes from 2001:4860:4802:36::75: seq=2 ttl=57 time=6.988 ms
64 bytes from 2001:4860:4802:36::75: seq=3 ttl=57 time=7.284 ms
^C
--- google.de ping statistics ---
4 packets transmitted, 4 packets received, 0% packet loss
round-trip min/avg/max = 6.270/7.109/7.897 ms
So why is IPv6 routing broken for clients?