DHCP request not received at br-lan

Hi,

In our system we are using eth0 and eth1 in bridge mode. So the client device is connected to the eth1 interface and when a dhcpv6 request is send from the client device we are able to see the request coming in eth1 using tcpdump. But we are not able to see the same request coming in br-lan interface.

  • Are you making an inquiry?
  • Configs?
config interface 'lan'
        option ifname 'eth1.643 eth0.643'
        option force_link '1'
        option type 'bridge'
        option proto 'dhcpv6'
        option ip6assign '64'
        option reqaddress 'try'
        option reqprefix 'auto'
        option ieee1905managed '1'

While you haven't provided your full config (so there could be more stuff wrong)...

This is a deprecated method of defining a bridge. You need to create a bridge device and then set your interface's device as the bridge device.

do you mean through brctl command ?

no, usually it looks like this:

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0.643 eth1.643'

config interface 'lan'
        option device 'br_lan'

One more doubt is this is from lan to wan right ? how do we configure if it from wan to lan. Since am new to openwrt am not sure how

I don't understand your question... when you bridge an interface, it is bidirectional. There is no concept of wan or lan here (except insofar as the physical labeling of the ports, if that applies in this case).

So do you mean there no separation configuration if we wanted traffic to flow from wan to lan ?

A bridge can be thought of as simply a wire between two ports... it means that there is no involvement with the firewall or routing engines.

actually in our setup the physically we have connected ISP to the LAN and from WAN to the client device. since both the ports are configured as in bridge mode it is not required to configure any setting for lan to wan or wan to lan traffic .

What is your goal? In most cases, bridging the WAN and LAN is a very bad idea. The exception would be if you are configuring a dumb AP or similar device that will not use the routing engine, or if you are configuring the device to simply pass specific network traffic through the device without any firewall or routing (such as IPTV traffic on a VLAN passing through the router untouched while the normal internet connection goes through the routing and firewall functions).

Actually we have configured eth0.643 and eth1.643 in our setup and added them to the bridge br-lan1.
So our client device is connected to eth1 and we are trying to get dhcpv6 request from the client to the server. But we are not able to received any IPV6 address in our client device. But in br-lan1 interface we are able to get IPV6 address. Is there any firewall setting we need to configure for the client device to get IPV6 address from the bridge interface

Is the client device configured to use VLAN ID 643 (tagged)?

yes we have configured vlan ID 643 in our client device

let's see your config file (/etc/config/network)

Please find my network config file attached.


config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'auto'

config switch
	option name 'switch0'

config interface 'lan'
	option ifname 'eth0.41 eth1.41'
	option force_link '1'
	option type 'bridge'
	option proto 'dhcp'

config interface 'lan1'
       option ifname 'eth1.643 eth0.643'
	option force_link '1'
       option type 'bridge'
       option proto 'dhcpv6'
	option ip6assign '64'
	option reqaddress 'try'
       option reqprefix 'auto'
	option ieee1905managed '1'

you didn't move the bridge definition as I had described earlier.

Also, do you need lan1 to have an address.. better using proto none if that interface doesn't need an address on that network. you can also remove everything else.

config device
	option name 'br-lan1'
	option type 'bridge'
	list ports 'eth0.643 eth1.643'

config interface 'lan1'
        option device 'br_lan1'
        option proto 'none'

I tried moving to the configuration as mentioned by you. But after those changes am not able to see my vlan id getting created and also the br-lan1 interface in my ifconfig

ubus call system board