DHCP question for new computer on working router

Hello, I am brand new to openwrt and am having an issue that I’m sure is easily fixed by an expert.

First, I was able to get a working openwrt on my Linksys WRT1900ACS connected to my intel NUC 5 that was running Tails OS from a usb drive (working for a few weeks).

I had a working Tor browser and could reboot back into a perfectly working tails os with everything functioning properly. I used the safe browser in Tails OS to configure my password for LuCI on the newly installed linksys/openwrt router. I deleted the SSH login cause I was not planning on using SSH or fail safe.

So I purchased a new intel NUC 10 (replacing the NUC 5) and was trying to install a clean Archlinux OS onto it.

I thought I would be able to just plug my Ethernet cable into the new NUC 10 and DHCP would configure the rest. Instead, I think it is stuck on the previous NUC 5/Tails OS lease and DHCP is not working for the Archlinux installer. (It has been a few years since using Linux so I am rusty on my networking commands)

My router works with the old NUC 5 and usb Tails OS. Using the same usb Tails OS with the new NUC 10 does not have a working network connection and am unable to open up safe browser to login to LuCI.

I am logged back into the intel NUC 5 and am logged into my LuCI but am not sure what to do next so that I can install Archlinux onto the NUC 10.

I think I should add something in the DHCP and DNS section but am not sure what to add for a new NUC 10 with no operating system installed on the hard drive.

I would also like to be able to still use the NUC 5 that still works, as well as be able to install new Linux distorts on both the NUC 5 and the new NUC 10 and use usb Tails OS as well as what distros that I install on the hard drives.

Any help or info would be appreciated, I was reading both the Arch wiki and OpenWRT wiki but did not find the answer yet, and I have not found a forum post with a similar issue yet.

Did you make any changes to the router's configuration?

1 Like

During the installation I deleted the SSH part. Other than that I did not change anything else from the stock settings.

nuc10 nic not supported by tails? did you test the nic with ifconfig / static ip (or another bootable distro maybe)?

I first tried to use the newest Archlinux install on the NUC 10 and could not ping the Archlinux.org (and I did not try static ip yet but will tonight). When using “ip route show” and “ip address show” I could see my eno1 Ethernet, and wlan, and lo, and the addresses that it was connected to. I gave up kind of quickly and was hoping for and easy solution from the DHCP and DNS section of LuCI.

Last week, before I tried to build the NUC 10, I had tried to install a NixOS onto my old NUC 5 and also could not get the DHCP to work during that installation and gave up quickly without trying to configure the static IP address. This was the same NUC 5 that was already working with my Tails OS usb drive... so I don’t think it’s the new hardware’s nic card since the NUC 5 and NixOS also failed to use DHCP properly during installation.

When I first flashed my Linksys 1900ACS I was using a Tails OS usb cause it was the only Linux distro that I had at the time. Maybe that was the wrong distro to use cause of all the weird iptables rules. (And the MAC spoofing might also have caused problems)

I’m going to try to use static ip tonight and maybe even redo my openwrt router to start fresh and see if it works from that.

Thank you both for trying to help.

I just tried the Tails OS and NUC 10 again and can not get any output from the command of “ip route show” and when using “ip addr” I see my WLANO and LO but do not see my ethernet so maybe the Tails OS might not have recent 10th gen intel support?

I am going to now try my Archlinux and NixOS installation live usb, and I’ll let you know how that goes with it recognizing my hardware.

1 Like

Ok, I just tried NixOS and Tails OS and neither recognized my Ethernet, but trying the Arch install it does recognize the eno1 ethernet as brd

Pinging Archlinux.org gets an error message of: Temporary failure in name resolution.