DHCP offer not received and sent on trunk interface

Hi guys,

The setup I have is :
Mikrotik Main router (AC2) ---- trunk ---- Openwrt 23.05 ---- trunk ---- Mikrotik wAP ac

Trunk carries vlans 5, 10, 90 (hotspot)
Openwrt : IP interfaces in each vlan, DHCP server disabled, all vlan interfaces put to same LAN zone (for now, just not to bother about rules)
Ports : lan3, lan4, wan = trunks; lan1 = vlan99 (local network only) ; lan 2 = acces vlan10
MT main connected on lan4; MT wAP ac connected on lan3

The thing is that DHCP served from main router (Mikrotik) works till Openwrt. If I have wifi there with proper SSID then clients from there got DHCP address assigned from main router.
But the issue is with second mikrotik, wifi with proper VLAN assigned cannot get IP address.

I tracked the issue using packet captures back to main MT router receiving DHCP Discover and sending DHCP offer, but Openwrt incoming trunk (hence outgoing as well) can't see any DHCP offer received from MT main..

Same thing works well when client is on Openwrt.
Is it issue with Openwrt or Main Mikrotik ?

Please, post your network config file here.


config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fda2:37eb:c605::/48'
	option packet_steering '1'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'
	list ports 'wan'

config bridge-vlan
	option device 'br-lan'
	option vlan '1'
	list ports 'lan3'
	list ports 'lan4'
	list ports 'wan'

config bridge-vlan
	option device 'br-lan'
	option vlan '5'
	list ports 'lan3:t'
	list ports 'lan4:t'
	list ports 'wan:t'

config bridge-vlan
	option device 'br-lan'
	option vlan '10'
	list ports 'lan2'
	list ports 'lan3:t'
	list ports 'lan4:t'
	list ports 'wan:t'

config bridge-vlan
	option device 'br-lan'
	option vlan '20'
	list ports 'lan3:t'
	list ports 'lan4:t'
	list ports 'wan:t'

config bridge-vlan
	option device 'br-lan'
	option vlan '30'
	list ports 'lan3:t'
	list ports 'lan4:t'
	list ports 'wan:t'

config bridge-vlan
	option device 'br-lan'
	option vlan '90'
	list ports 'lan3:t'
	list ports 'lan4:t'
	list ports 'wan:t'

config bridge-vlan
	option device 'br-lan'
	option vlan '99'
	list ports 'lan1'

config interface 'lan1'
	option proto 'dhcp'
	option device 'br-lan.1'

config interface 'lan5'
	option proto 'static'
	option device 'br-lan.5'
	option ipaddr '10.0.0.2'
	option netmask '255.255.255.0'

config interface 'lan10'
	option proto 'static'
	option device 'br-lan.10'
	option ipaddr '10.1.10.2'
	option netmask '255.255.255.0'
	option gateway '10.1.10.1'
	list dns '1.1.1.2'
	list dns '1.0.0.2'

config interface 'lan20'
	option proto 'static'
	option device 'br-lan.20'
	option ipaddr '10.1.20.2'
	option netmask '255.255.255.0'
	option defaultroute '0'

config interface 'lan90'
	option proto 'static'
	option device 'br-lan.90'
	option ipaddr '10.1.90.2'
	option netmask '255.255.255.0'
	option defaultroute '0'

config interface 'lan99'
	option proto 'static'
	option device 'br-lan.99'
	option ipaddr '192.168.10.1'
	option netmask '255.255.255.0'

config interface 'lans'
	option proto 'static'
	option device '@lan1'
	option ipaddr '192.168.1.5'
	option netmask '255.255.255.0'

Issue has been narrowed down to second mikrotik bad configuration