Dhcp miss option 3 from Reply

Hi guys, i need help with an issue on dhcp, i use this version of openwrt

DISTRIB_ID='OpenWrt'
DISTRIB_RELEASE='19.07.7'
DISTRIB_REVISION='r11306-c4a6851c72'
DISTRIB_TARGET='ath79/nand'
DISTRIB_ARCH='mips_24kc'
DISTRIB_DESCRIPTION='OpenWrt 19.07.7 r11306-c4a6851c72'
DISTRIB_TAINTS='busybox'

when a client send a request to dhcp server, the server responde with the 3 dhcp option, but the client request not receive the 3 option, this is the request made by client, i captured it with this tcpdump -nni interface -vv

13:32:43.859266 b2:98:3d:a5:43:a6 > ff:ff:ff:ff:ff:ff Null Unnumbered, xid, Flags [Response], length 6: 01 00
13:32:44.015448 IP (tos 0x10, ttl 64, id 0, offset 0, flags [DF], proto UDP (17), length 334)
    0.0.0.0.68 > 255.255.255.255.67: [udp sum ok] BOOTP/DHCP, Request from b2:98:3d:a5:43:a6, length 306, xid 0x8b0f51ab, Flags [none] (0x0000)
	  Client-Ethernet-Address b2:98:3d:a5:43:a6
	  Vendor-rfc1048 Extensions
	    Magic Cookie 0x63825363
	    DHCP-Message Option 53, length 1: Request
	    Client-ID Option 61, length 7: ether b2:98:3d:a5:43:a6
	    Requested-IP Option 50, length 4: 172.16.178.57
	    MSZ Option 57, length 2: 1500
	    Vendor-Class Option 60, length 15: "android-dhcp-11"
	    Hostname Option 12, length 10: "OnePlus-8T"
	    Parameter-Request Option 55, length 12: 
	      Subnet-Mask, Default-Gateway, Domain-Name-Server, Domain-Name
	      MTU, BR, Lease-Time, RN
	      RB, Vendor-Option, URL, Option 108

this is the response of the server

13:32:44.030536 IP (tos 0xc0, ttl 64, id 64823, offset 0, flags [none], proto UDP (17), length 328)
    172.16.176.1.67 > 172.16.178.57.68: [udp sum ok] BOOTP/DHCP, Reply, length 300, xid 0x8b0f51ab, Flags [none] (0x0000)
	  Your-IP 172.16.178.57
	  Server-IP 172.16.176.1
	  Client-Ethernet-Address b2:98:3d:a5:43:a6
	  Vendor-rfc1048 Extensions
	    Magic Cookie 0x63825363
	    DHCP-Message Option 53, length 1: ACK
	    Server-ID Option 54, length 4: 172.16.176.1
	    Lease-Time Option 51, length 4: 3600
	    RN Option 58, length 4: 1800
	    RB Option 59, length 4: 3150
	    Subnet-Mask Option 1, length 4: 255.255.252.0
	    BR Option 28, length 4: 172.16.179.255
	    Default-Gateway Option 3, length 4: 172.16.176.1
	    Domain-Name-Server Option 6, length 4: 172.16.176.1

and this is the packet that arrived on the gl-inet ar750s

13:09:09.385338 IP (tos 0xc0, ttl 64, id 56891, offset 0, flags [none], proto UDP (17), length 328)
    172.16.176.1.67 > 172.16.178.57.68: [udp sum ok] BOOTP/DHCP, Reply, length 300, xid 0xa7d919b7, Flags [none] (0x0000)
	  Your-IP 172.16.178.57
	  Server-IP 172.16.176.1
	  Client-Ethernet-Address b2:98:3d:a5:43:a6
	  Vendor-rfc1048 Extensions
	    Magic Cookie 0x63825363
	    DHCP-Message Option 53, length 1: ACK
	    Server-ID Option 54, length 4: 172.16.176.1
	    Lease-Time Option 51, length 4: 3600
	    RN Option 58, length 4: 1800
	    RB Option 59, length 4: 3150
	    Subnet-Mask Option 1, length 4: 255.255.252.0
	    BR Option 28, length 4: 172.16.179.255
	    Domain-Name-Server Option 6, length 4: 172.16.176.1

as you can see the option 3 is miss,the dhcp server is outside the ar750s,
clients connect to wlan0 which is bridged with an openvpn interface .
the dnsmasq server is configured at the other end of the vpn.
My network configuration is

config interface 'loopback'                                                                                                                                                                                                                                                                                                  
        option ifname 'lo'                                                                                                                                                                                                                                                                                                   
        option proto 'static'                                                                                                                                                                                                                                                                                                
        option ipaddr '127.0.0.1'                                                                                                                                                                                                                                                                                            
        option netmask '255.0.0.0'                                                                                                                                                                                                                                                                                           
                                                                                                                                                                                                                                                                                                                             
config globals 'globals'                                                                                                                                                                                                                                                                                                     
        option ula_prefix 'fd64:4195:6d54::/48'                                                                                                                                                                                                                                                                              
                                                                                                                                                                                                                                                                                                                             
config interface 'lan'                                                                                                                                                                                                                                                                                                       
        option type 'bridge'                                                                                                                                                                                                                                                                                                 
        option ifname 'eth0.1'                                                                                                                                                                                                                                                                                               
        option proto 'static'                                                                                                                                                                                                                                                                                                
        option ipaddr '10.5.0.1'                                                                                                                                                                                                                                                                                             
        option netmask '255.255.255.0'                                                                                                                                                                                                                                                                                       
        option ip6assign '60'                                                                                                                                                                                                                                                                                                
                                                                                                                                                                                                                                                                                                                             
config interface 'wan'                                                                                                                                                                                                                                                                                                       
        option ifname 'eth0.2'                                                                                                                                                                                                                                                                                               
        option hostname 'GL-AR750S-070'                                                                                                                                                                                                                                                                                      
        option metric '10'                                                                                                                                                                                                                                                                                                   
        option proto 'dhcp'                                                                                                                                                                                                                                                                                                  
        option disabled '0'                                                                                                                                                                                                                                                                                                                                                                                                                                                                               
        option ipv6 'auto'                                                                                                                                                                                                                                                                                                   
                                                                                                                                                                                                                                                                                                                             
config interface 'wan6'                                                                                                                                                                                                                                                                                                      
        option ifname 'eth0.2'                                                                                                                                                                                                                                                                                               
        option proto 'dhcpv6'                                                                                                                                                                                                                                                                                                
                                                                                                                                                                                                                                                                                                                             
config switch 'switch0'                                                                                                                                                                                                                                                                                                      
        option enable_vlan '1'                                                                                                                                                                                                                                                                                               
        option name 'switch0'                                                                                                                                                                                                                                                                                                
        option reset '1'                                                                                                                                                                                                                                                                                                     
                                                                                                                                                                                                                                                                                                                             
config switch_vlan 'switch0_vlan1'                                                                                                                                                                                                                                                                                           
        option device 'switch0'                                                                                                                                                                                                                                                                                              
        option ports '2 3 0t'                                                                                                                                                                                                                                                                                                
        option vlan '1'                                                                                                                                                                                                                                                                                                      
                                                                                                                                                                                                                                                                                                                             
config switch_vlan 'switch0_vlan2'                                                                                                                                                                                                                                                                                           
        option device 'switch0'                                                                                                                                                                                                                                                                                              
        option ports '1 0t'                                                                                                                                                                                                                                                                                                  
        option vlan '2'                                                                                                                                                                                                                                                                                                      
                                                                                                                                                                                                                                                                                                                             
config switch_vlan 'switch0_vlan9'                                                                                                                                                                                                                                                                                           
        option device 'switch0'                                                                                                                                                                                                                                                                                              
        option ports '0t 2t 3t'                                                                                                                                                                                                                                                                                              
        option vid '9'                                                                                                                                                                                                                                                                                                       
        option vlan '9'                                                                                                                                                                                                                                                                                                      
                                                                                                                                                                                                                                                                                                                             
config interface 'monitvpn0'                                                                                                                                                                                                                                                                                                 
        option ifname 'monitvpn0'                                                                                                                                                                                                                                                                                            
                                                                                                                                                                                                                                                                                                                             
config interface 'cp'                                                                                                                                                                                                                                                                                                        
        option auto '1'                                                                                                                                                                                                                                                                                                      
        option enabled '1'                                                                                                                                                                                                                                                                                                   
        option ifname 'wlan0 tcp-vpn1.54'                                                                                                                                                                                                                                                                                    
        option igmp_snooping '1'                                                                                                                                                                                                                                                                                             
        option mtu '1500'                                                                                                                                                                                                                                                                                                    
        option proto 'none'                                                                                                                                                                                                                                                                                                  
        option stp '0'                                                                                                                                                                                                                                                                                                       
        option type 'bridge'                                                                                                                                                                                                                                                                                                 
                                                                                                                                                                                                                                                                                                                             
config interface 'wlan0'                                                                                                                                                                                                                                                                                                     
        option auto '1'                                                                                                                                                                                                                                                                                                      
        option enabled '1'                                                                                                                                                                                                                                                                                                   
        option ifname 'wlan0'                                                                                                                                                                                                                                                                                                
        option mtu '1500'                                                                                                                                                                                                                                                                                                    
        option proto 'none'

is your device hosting the DHCP your main router ?

hi, thank you for the response,
the dnsmasq server is configured outdside of the ar750s

and if you set up your VPN directly on the phone, does it get the router (gw) option ?

hi, no i setup openvpn on the ar750s and bridge the vpn with wlan0, on the other side of the vpn there is a dnsmask service that give me the address

That wasn't what I asked/told you.

sorry you are right, i can't set up the vpn directly on the phone