DHCP limit address range and disable IPv6?

Hi I recently switched over to OpenWRT 19.07.0-rc2 from Tomato. In Tomato web interface there's a way to limit the DHCP address range. I cannot find anything similar in the LuCI web interface. I have various addresses in Virtual Machines that are statically assigned and I don't want the DHCP server giving out those addresses, so I need to limit the range to .100 - .149 if it does not do that already.

Also I want to disable IPv6. I found directions in this forum several days ago that suggested:

cat >> /etc/sysctl.conf

However despite that I still have a WAN6 with an IPv6 address and I am seeing these two DHCP errors continually in the log:

Sat Nov 30 16:23:53 2019 daemon.err odhcpd[846]: Failed to send to ff02::1%lan@br-lan (Permission denied)
Sat Nov 30 16:25:26 2019 daemon.err odhcp6c[1105]: Failed to send DHCPV6 message to ff02::1:2 (Permission denied)

Short of creating a special build with IPv6 disabled how can I shut it off? Thanks

I'd say Network -> Interfaces -> Wan -> "Use builtin IPv6-management" (uncheck)

The DHCP range is under Network -> Interfaces -> LAN -> Start / Limit

You can just delete the wan6 interface, untick boxes for IPv6, disable IP6ASSIGNMENTS, disable RAs and DHCP6D. However full removal of IPv6 is not a supported configuration.


Ok thanks guys. I've made these changes:

LAN > Advanced > UNCHECK: Use IPv6-management
LAN > DHCP > General > Start > 100
LAN > DHCP > General > Limit > 50 (Log confirms this sets the range to 100-149)
LAN > DHCP > IPv6 > Disable everything
WAN > Advanced > UNCHECK: Use IPv6-management
WAN6 > Delete

During the first two minutes of startup there's still IPv6 messages from the router (multicast listener and router solicitation) but after that nothing which for my purposes is fine.

1 Like

If your problem is solved, feel free to mark the relevant post as the solution; and edit the title to add "[SOLVED]" to the beginning (click the pencil behind the topic).


1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.