DHCP and DNS no longer in Network tab

Openwrt installed on Netgear R6220's for several years now. One of these is the "master" offering dhcp and dns, and the others are dhcp clients feeding a small home network of about 50 devices. Until early this afternoon the master was serving dhcp requests and the DHCP and DNS options were under the Network tab on the GUI. Suddenly my 3D printers were unable to communicate to the Octopis; the PiAware no longer communicates and can't be found on the net. Most confusing is that when I try to ping 192.168.xxx.71 it pings 192.168.xxx.158.

Since DHCP seemed the most likely suspect, I checked the GUI and found several options missing from the network tab. SSHing into the router, a ps | grep dhcp finds the expected services running for both dhcp and dns. Starting and stopping them has no effect. The log shows that dhcp requests are being honored, but not from the dhcp file I configured in /etc/config.

Tried an upgrade to the latest Openwrt (19.07.6), to no avail. Opening Network -> interfaces and looking at LAN the DHCP tab states that there is no DHCP server configured. The option to configure a DHCP server does nothing.

Not sure what happened to this router setup. Was working on making wifi extenders with the wavlink wl-wn570ha1's using MDS, but can't believe that enabling the MDS on the wireless ports would cause this. Not sure where to look next since the reinstall of the software did not fix the problem.

Since this is the first time that I have had to post to the forum, having been able to find most problems already solved in the past, I would appreciate any suggestions. If you need more information I can accommodate. Also since I am not sure if this is the best place to post the problem, would appreciate if some steered me to the correct place.


I would suggest to reset at least the networking and dhcp configuration to its defaults and start over from there, before gradually adding back your necessary settings.

1 Like

Thanks! I'll do that with a completely fresh install of 19.07.6. I'll see where that ends up, instead of using the backups. Still can't figure out why after almost three years it decided to go. Gremlins.