DGS-1210-10P can't access webui

I got a d-link DGS-1210-10P. I have used OpenWrt on some other devices in the past and therefore thought I could just start the same way I always did. Download the appropriate firmware image, flash it on the device using the existing webUI and then use the OpenWrt webUI to set it up.
Well I guess I f*ed up. I downloaded the firmware (https://firmware-selector.openwrt.org/?version=22.03.3&target=realtek%2Frtl838x&id=d-link_dgs-1210-10p - Factory_image1). It installed just fine as image1, I rebooted and - nothing.
I do get an IP via DHCP (, but it is in a wierd subnet and I seem to be unable to access the webUI.
I looked at the wiki article before installation and I didn't see anything similar to this problem. Did I do somehting wrong?
Can someone please tell me how to access the UI or how to boot the device into image2? Someway to access the device via SSH, Telnet or similar would also be appreciated.

FYI, this is not a DHCP-issued IP.

See: https://www.pcmag.com/encyclopedia/term/link-local-address

Can you provide that link?

I cannot locate a Wiki that contains installation instructions for your device.

Thanks, yeah, I am a bit unsure cause I currently have the switch connected to a windows device and it reports the IP as DHCP issued or at least says: DHCP: yes.

I also tried assigning my self and then to access without luck.

Of course:

What revision is your device?

According to the box it is H/W Ver.: F1 F/W Ver.: 6.30.016

Is traffic passing through the switch normally? What is the subnet of your lan?

Interesting, hadn't tested that yet as I was unable to contact the device but it does work just fine as a dumb switch.

Edit: It seems to be completely transparent to the network as one would expect an unmanaged switch. It has no IP lease from the DHCP and I can't see it on a tracert.

What about this?

And what port(s) do you have connected? (what is connected to each of those ports?)

The computer is connected to port 1 and the rest of my network is on port 4.
The rest of the network uses problem is that in this network there is already a router on where I would expect the default OpenWrt. Trying to access shows the router web interface. I could try to change the routers IP.

I would suggest you disconnect everything from the switch besides your PC on lan1.
Then try again.
If still no IPv4 lease comes, ping ff02::1, you should see two replys. One is your PC and the other the switch hopefully. Then use this address to ssh into the switch and see if luci is even installed and what the network config says...

Edit: or just ping ff02::2 which should just list the switch address as forwarding is enabled by default


Before psherman asked about it passing traffic it was not connected to the rest of my network. So: no IPv4 lease coming.
Also both ping ff02::1 and ping ff02::2 came up empty

Pinging ff02::2 with 32 bytes of data:
Request timed out.
Request timed out.

As @_bernd suggested, connect your PC to lan1. Unplug everyhing else.
Set your PC's ethernet port IP address manually (static) to, subnet mask
Make sure this is the only network conenction from your PC (disable wifi, etc).

See if you can ping

1 Like

That was the first thing I tried after seeing that I didn't get a DHCP lease, except that I used for my address and it was on port 2.
I tried again with but I still can't connect to with ping, ssh or browser.

the exact IP address doesn't matter as long as it is in the network and is not

You probably need to be on port 1. It's not entirely clear to me if you need to be on a VLAN... that may be a thing, too.

OK, things got a bit weirder. I power cycled the switch. That's the third boot (1: I bought it and installed the OpenWRT firmware; 2: reboot after the installation; 3: just yet)
I was still unable to reach but because I'm desperate I also tried changing my IP and going to the D-Link web interface at - that one didn't work after the second boot but now after the third boot it is back.

On the wiki it says

Known broken F1 firmware versions for this procedure: 6.30.016

Could you downgrade the stock fw to

Known working F1 firmware versions for this procedure: 6.20.B009

1 Like

That might be difficult, quoting from D-Link's firmware release notes for V6.30.016:

The new image file (*.con) is encrypted which starting from v6.30.016. It
needs upgrading to f/w v6.30.16 (.hex) first if attempting to upgrade from
(v6.20 or older) to v6.30 (.con).
Use v6.30.016 backup encrypted firmware file (.con) to upgrade firmware
size will change to 12775084B, normal v6.30.016 hex file upgrade firmware
size is 12774896B.

What can -or cannot- be done, needs to be determined by someone with the hardware and serial console attached.

The network interfaces section seems to indicate that you need to be on tagged VLAN 100 on port 1 to reach the device ( but earlier on the page, it talks about the network config for 21.02 being broken... so not entirely clear.

Do you have the ability to try VLAN 100 tagged? Does your computer have easy ability to set VLANs? Or if not, do you have another managed switch (or even an OpenWrt main router with a built in switch) that could be used to handle tagging?

AArrrgghhh. I already have an other D-Link box that refuses to cooperate. narf

Well I have the hardware and I am willing to test it but the device doesn't have a serial interface. If I go looking I should be able find a serial adapter somewhere but would I have to open it to find something like a JTAG?

This is very simple home network. I have a modem, an access point (not yet in use, also a d-link one i want to flash with openwrt - if this doesn't work either I think I will cry), a windows computer, an Arch Linux computer, a raspi, an android phone and a switch. Nothing fancy.

For now I am sorry but it is late where I am. Will try again tomorrow and report back.

While that would be an issue with 21.02.x:

it's no longer required for 22.03.x (but that also implies dnsmasq/ odhcpd no longer being preinstalled, it's a switch, not a router - and by default, there is no WAN anymore).

So setting a static IP in the 192.168.1.x subnet and trying to access the switch on would be the way to go - but it's totally unclear what happens on a device which had OEM firmware V6.30.016 installed, prior to flashing OpenWrt.

If ssh access can't be established, serial console access will be required.