Devices not auto-connecting to the router after a wifi restart

am using gl-ar750s as my openwrt router.
Am trying to find a way to turn the wifi on and off from the shell.

I've noticed a strange behavior.
If I just do:

$ wifi

The wifi will drop and all devices connected to the router access point will lose the wifi connection.
After 10+ seconds the devices will detect the wifi again and auto connect.

However if instead do:

$ wifi down
# Wait 30 sec
$ wifi

The same will happen but no automatic reconnects will occur.
I can manually connect to that wifi on the clients with the same credentials (no need to reenter them) and SSID. But for some reason this doesn't trigger the automatic restart.

Is this something conceptually different with the two approaches from the point of view of the wifi command?

No, the only thing that is different is the waiting time you introduce in the second case. wifi is the same as wifi up and if called when wifi is already up will first turn off wifi, then turn it back on.
Most likely your clients are going into power saving mode after not detecting the available wifi after some time since disconnection.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.