Devices don't get an IP

i need some help with an Issue I'm currently having.
I have two shelly relays that were connected to my WRT3200acm.
I did make them a static IP.
However, i had to factory reset my WRT3200acm , and now when i connect the shellys again, they only show up as a question mark (See Screenshot).
The same thing also happened with a Sonoff device.
I did already factory reset the Shellys, but they still only show up as a question mark (See Screenshot).

The Static IP that was set for the devices were all out of the DHCP range.

Does anyone have a clue to what might be going on here ?

@Dith-byte, welcome to the community!

Yes. Static IPs don't "talk" to OpenWrt, hence no hostname displayed - and no IP displayed. That data is based on the DHCP service, setting Static IPs (obviously) circumvents that.

(FYI, the same display occurs when e.g. a client connection to an upstream AP is made - because the OpenWrt is not issuing the IP.)

1 Like

Try to ping those two clients from the OpenWrt (either from SSH or from the diagnostics page) and check again.


Thank you for the fast reply,
the problem is that I don't know the IP address anymore, I have tried using "arp -a", but the MAC Address of the devices is not getting listed...
Is there any way I can find out the IP with only the MAC Address?
I'm sorry, I'm pretty new to this.

If you forgot what you configured:

1 Like

Thank you very much!
And thank you for the fast reply.
I understand now, sounds logical....
The Problem that I'm having now is that I don't know the IP of the devices, and they are not Autodetectet in the Shelly app, which is very strange.Is there any way I can find out the IP address with only the MAC address?

Your best bet is to check the arp table in the gateway.
Or try with broadcast ping or some network scanner.


I answered.

I know of no way except to scan with an IP in a subnet of /0 as @trendy notes. I think it's easier to reset the device, though.

I presume the devices are still in the same network the 3200 is, so he doesn't have to scan the whole 0/0.


I imagine that should be "the same network the 3200 was"

1 Like

Well, the 3200 has the same IP Address as before(
I already did factory reset the router (Pushing the reset button for 10 Sec), and the flashing the original firmware on it and then back again to openWRT.

Then use an IP scanner on

I already did Scan my whole network, it does not show up.
It is very strange...

They you could try resetting one of the devices. That's probably easier than scanning

Thats the thing, i already factory reset both thr Router and the shellys numerous times, always with the same outcome, that i can connect the shellys with out any problem to my router, but then i cant find their IP, it does not show up anywhere...

If you reset them then they will either be DHCP client or HAVE manufacturer default static IP. The user manual should tell you.


So, i factory reset my Router and the switch.
I only entered the wifi credentials and again its only showing the "?"
Could it be that there is something wrong with the Router? is there a way to completely reset the router?

I also factory reset the Shellys.
I just connected that way :

I did not set a Static IP, so in theory the DHCP should give the Shelly a IP ? or am i wrong ?
how ever, once it is connected it shows up that way :

on the Second shelly i tried with a Static IP :

with the same result...

What's the issue here? Is it that you can't access the devices at all, or just that the IP doesn't display in Luci?

Hello, the issue is that I can't access the device at all, I tried letting the DHCP give the device an IP but it did not do that, and when I try to give the device a static IP I can't connect to it, and I don't even find it with an IP scanner.