Devices connected to WiFi become sluggish to load data (R7800)

Opened this with some details upstream. I am out of ideas but this problem is absolutely reproducible for me.

For Apple devices, it is recommended to use DTIM = 3, default is 2.

uci set wireless.wifinet0.dtim_period='3'

replace the interface name to match your config.

And do it for both radios.
Not that I expect this will fix your issue, but it might help. I have a ton of new and old Apple devices, never have an issue with those devices. (my router is MT76 7621/7603 running 19.07.3).

Thank you for the suggestion. Can you point me to a reference for the change? Also, is this setting exposed in luci somewhere or purely accessible via the uci set call?

I have the same problem: the download speed drops to 10..20% of what is should be while upload remains the same and I was also blaming wifi (which might still be a problem), but I am not using the -ct firmware. After rebooting the router several times I found out that it is enough to only restart the wan interface. When this issue happens again, do you want to try restarting individual interfaces instead of all of hem? ifdown wan; ifup wan fixes it for me.

You can set Dtim via luci, it is in the Advanced settings tab of the wifi interface. I also bump the group rekey interval (GTK) to one day (86400), as some combo's of WRT drivers and mobile OSs (looking at you, Android) work better if rekeys are spread apart.

Here is a well documented article on exactly why the DTIM needs to be raised:

In the Ubiquity forums, some guys recommend DTIM 6 on 2.4 and 3 on 5GHz. But I find 3 on both is just fine.


Thanks for info and passing the link along. I modified it and will try out the ct driver again.

I'm not sure that the download speed drop is what I am experiencing... mine is very specific to laggy search results and a characteristic high ping. I still get good throughput with a speed test app (up and down). I will try your suggestion just for kicks.

Lag and high pings is how I know that I need to restart wan...

Is your downlink faster 100Mbps? I see mine dropping from 340Mbps down to ~60Mpbs and restarting wan fixes that and lag/latency.

It's 200 down. I switched back to the ath10k-ct driver and tried your suggestion as my iphone was experiencing the issue, but it did not help. Still experiencing it.

1 Like

Could one or more of these patches be to blame? I couldn't find them upstream.;a=tree;f=package/kernel/ath10k-ct/patches;h=9c89a2ecd0e8947ae28c53779b66a45dab66f30b;hb=HEAD

An update: the ath10k-ct firmware or drivers are to blame. I have been working with Ben Greear with this ticket as currently open.

If you are experiencing this issue, recommend you switch to the ath10k driver/firmware which solves it for me.

1 Like

Hi Darksky,
I have similar issues but not only on 5Ghz. 2.4Ghz is impacted too. It happens on my iphones 8 and XR but not an ipad mini 4. The browsing is just slow (hit on google gives inconsistent response time)
I've read the github issue and I want to congrat for the follow-up you did: really appreciated.
My conclusion of my read is: with Openwrt on R7800, we should:

  • use non-ct drivers
  • disable any mac filtering
  • configure DTIM to use the value 3
    Is that correct or do I miss something?

Not actually sure if diabling mac filtering and DTIM mods are needed (sure they can't hurt). It's definitely the -ct drivers.

Ok, thanks for feedback. Will try for one week and give feedback here.