Devices connected to WiFi become sluggish to load data (R7800)

I’d set your transmission power to a set number. Usually mid 20’s usually works well. 30 should be the max. A set number will give consistent results over the default.

What types of wireless clients are having issues - all of them or only some? Zero issues with wired clients now that the modem is fixed? What does dsl speed reports testing look like (less lag?).

I have super simple SQM settings. Never really found great benefit from advanced settings - anything unique with your SQM setup?

root@OpenWrt:~# cat /etc/config/sqm

config queue 'eth0'
        option interface 'eth0.2'
        option enabled '1'
        option debug_logging '0'
        option verbosity '5'
        option upload '32500'
        option download '0'
        option qdisc 'fq_codel'
        option script 'simplest_tbf.qos'
        option qdisc_advanced '0'
        option linklayer 'ethernet'
        option overhead '22'

According to luci, the "maximum transmit power" is "driver default" which is 23 dBm which is the maximum from the pulldown. I can force a setting of "23 mBm (199 mW)" from the pulldown... is there something I can inspect to see what the current is (verbiage indicated max but driver can reduce).

EDIT: Here is how to see the actual power I believe.

# iwinfo|grep Tx
          Tx-Power: 23 dBm  Link Quality: 38/70
          Tx-Power: 23 dBm  Link Quality: 54/70
          Tx-Power: 0 dBm  Link Quality: unknown/70

I see it on the following devices based on pinging said device from the OW router:
*iPhone 7
*iPhone 8 Plus
*iPad Air 2
*Macbook Air

For whatever reason, I do not see it on the following:
*Lenovo P1
*Raspberry Pi4B (connected via wireless)
*iPhone 11

Regarding SQM, I have the following:

# cat /etc/config/sqm

config queue 'eth1'
	option qdisc_advanced '0'
	option interface 'eth0.2'
	option verbosity '5'
	option linklayer 'ethernet'
	option overhead '22'
	option upload '11500'
	option qdisc 'fq_codel'
	option debug_logging '0'
	option enabled '1'
	option download '225000'
	option script 'simplest_tbf.qos'

Select one of the manual transmit powers. You can pull your wireless settings via cat and see if it gives you steady results. SQM settings look good.

You have a good diversity of clients. Those wireless devices you are not seeing might be asleep. Lag with all clients or just some clients?

Lag only with a few clients, just the older iphone, ipad, and macbook. Other devices connected at the same time the iphones are lagging do not show the lag. This can be measured qualitatively by watching a google hit set take 5-20+ seconds to appear, or directly by pingging the device from the OW router and seeing those really long ping times and packet loss.

The first symptom is slow web browsing on the device when this problem is occurring. I can confirm it by pinging that device so I know it is not asleep.

Interesting that it is only the apple devices.

  1. Any unique network configuration for these, unique DNS, or anything else changed from the default openwrt config?

  2. Running adblock or any other additional programs you are running that could be jacking with particular website functioning?

  3. You could try doing a “reset network settings” on one of these older apple devices and see if there are gremlins in the remembered client network settings.

  4. You could update your router to the latest hynman master build (CT or ath10k - you have two different wifi driver options, I’d try both options)

  5. lastly - you could select not to keep your configuration so that you start with the default settings if you think there might be a bug from prior configuration changes.

Beyond the above posts on simplifying/tweaking the configuration settings, trying a different wifi driver, considering reseting clients +/- the router to default configuration - I’m out of any additional tips or tricks. Hope one of the above helps! :sunglasses:

My wifi settings for 5ghz (for comparison if anything is different):

root@OpenWrt:~# uname -a
Linux OpenWrt 5.4.42 #0 SMP Tue May 26 15:52:03 2020 armv7l GNU/Linux

root@OpenWrt:~# cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11a'
        option path 'soc/1b500000.pci/pci0000:00/0000:00:00.0/0000:01:00.0'
        option htmode 'VHT80'
        option channel '161'
        option txpower '22'
        option legacy_rates '0'
        option country 'US'
        option beacon_int '101'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ft_over_ds '1'
        option ssid '*****'
        option ft_psk_generate_local '1'
        option key '*****'
        option ieee80211r '1'
        option encryption 'psk2+ccmp'
        option ieee80211k '1'
        option bss_transition '1'
        option ieee80211v '1'

Thanks for all the suggestions.

  1. No unique settings within the idevices.
  2. Running pihole on a RPi but it is not serving DHCP, it is just blocking ads
  3. I tried the reset network config but it did not help
  4. I tried running the latest hnyman build but experienced the same issues with it (did not switch drivers, just used what came on out-of-the-box which I believe is CT.
  5. I might do a factory reset and rebuild my configuration from scratch just to rule it out.

The only non-standard thing I have is physical port #4 is VLANed to be on the guest zone I created. Beyond that, I have a pretty standard "LAN" and "Guest" zone setup.

I did a factory reset and setup a simple 5 GHz SSID. I did not experience the lag initially but it did occur eventually. I thought it was due to another client joining, but it seems inconsistent.

I have switched to the ath10k (not ath10k-ct) and have been using it for 5 days now without any issue.

Opened this with some details upstream. I am out of ideas but this problem is absolutely reproducible for me.

For Apple devices, it is recommended to use DTIM = 3, default is 2.

uci set wireless.wifinet0.dtim_period='3'

replace the interface name to match your config.

And do it for both radios.
Not that I expect this will fix your issue, but it might help. I have a ton of new and old Apple devices, never have an issue with those devices. (my router is MT76 7621/7603 running 19.07.3).

Thank you for the suggestion. Can you point me to a reference for the change? Also, is this setting exposed in luci somewhere or purely accessible via the uci set call?

I have the same problem: the download speed drops to 10..20% of what is should be while upload remains the same and I was also blaming wifi (which might still be a problem), but I am not using the -ct firmware. After rebooting the router several times I found out that it is enough to only restart the wan interface. When this issue happens again, do you want to try restarting individual interfaces instead of all of hem? ifdown wan; ifup wan fixes it for me.

You can set Dtim via luci, it is in the Advanced settings tab of the wifi interface. I also bump the group rekey interval (GTK) to one day (86400), as some combo's of WRT drivers and mobile OSs (looking at you, Android) work better if rekeys are spread apart.

Here is a well documented article on exactly why the DTIM needs to be raised:

In the Ubiquity forums, some guys recommend DTIM 6 on 2.4 and 3 on 5GHz. But I find 3 on both is just fine.

1 Like

Thanks for info and passing the link along. I modified it and will try out the ct driver again.

I'm not sure that the download speed drop is what I am experiencing... mine is very specific to laggy search results and a characteristic high ping. I still get good throughput with a speed test app (up and down). I will try your suggestion just for kicks.

Lag and high pings is how I know that I need to restart wan...

Is your downlink faster 100Mbps? I see mine dropping from 340Mbps down to ~60Mpbs and restarting wan fixes that and lag/latency.

It's 200 down. I switched back to the ath10k-ct driver and tried your suggestion as my iphone was experiencing the issue, but it did not help. Still experiencing it.

1 Like

Could one or more of these patches be to blame? I couldn't find them upstream.;a=tree;f=package/kernel/ath10k-ct/patches;h=9c89a2ecd0e8947ae28c53779b66a45dab66f30b;hb=HEAD

An update: the ath10k-ct firmware or drivers are to blame. I have been working with Ben Greear with this ticket as currently open.

If you are experiencing this issue, recommend you switch to the ath10k driver/firmware which solves it for me.

1 Like

Hi Darksky,
I have similar issues but not only on 5Ghz. 2.4Ghz is impacted too. It happens on my iphones 8 and XR but not an ipad mini 4. The browsing is just slow (hit on google gives inconsistent response time)
I've read the github issue and I want to congrat for the follow-up you did: really appreciated.
My conclusion of my read is: with Openwrt on R7800, we should:

  • use non-ct drivers
  • disable any mac filtering
  • configure DTIM to use the value 3
    Is that correct or do I miss something?