Devices connected to router work fine, but the router itself has no Internet connectivity (Linksys E8450)

I have successfully installed OpenWrt on a Linksys E8450 (JP) by following this guide

The Linksys sits behind a fibre modem ( RX-600MI). https://web116.jp/shop/hikari_r/600mi/600mi_00.html I gave the Linksys a static IP there.

There is one issue with getting the updated package list. I get this error:

Downloading https://downloads.openwrt.org/releases/22.03-SNAPSHOT/targets/mediatek/mt7622/packages/Packages.gz

*** Failed to download the package list from https://downloads.opewrt.org/releases/22.03-SNAPSHOT/targets/mediatek/mt7622/packages/Packages.gz

I can not ping external IP addresses, or domain names, but devices connected to the Linksys have normal Internet connectivity. I can ping devices on the local network, but (as a side note) I only see one device with a DHCP lease in the status tab, even though three devices are connected to that wifi.

I have tried different DNS servers, to no avail.

When searching for solutions, I found mention of changing https to http, but of course it won't matter if I can not get DNS resolved.

So, as the devices connected to the Linksys have connectivity, but the Linksys itself does not, that leaves me somewhat confused ...

Did you change the LAN subnet.

Both the modem and router have the same default subnet 192.168.1.0/24

You need to change one of them

Thank you for the reply.

The modem is set to 192.168.1.1 and the Linksys is set to 192.168.2.1. Is that what you are referring to? I had that previously, but it also did not work. Well, I just tried again to separate the two as above and rebooted everything, but there is no change. I did remove the static IP as well, just in case.

There was a change after all, I can not connect internet anymore on my laptop. The phones are still fine.

How are the two devices connected to each other? LAN-LAN, or LAN > WAN?

Are you using a static IP or DHCP? If static IP, did you set the gateway?

Thank you for the reply.

The setup is:

Fibre -> RX-600MI - LAN port 3 then connects to "Internet" port on Linksys, thereafter just wifi.

This is from the settings for LAN.There is the IP of the modem set for gateway (it looks greyed out though), but I do not remember entering it there. Is that the correct way of doing it?

What is the WAN setting on the router

Here is a screenshot:

image

There is another change now, I just noticed. I can now ping downloads.openwrt.org in the diagnostics tab.

PING downloads.openwrt.org (168.119.138.211): 56 data bytes
64 bytes from 168.119.138.211: seq=0 ttl=54 time=257.262 ms
64 bytes from 168.119.138.211: seq=1 ttl=54 time=253.897 ms
64 bytes from 168.119.138.211: seq=2 ttl=54 time=254.161 ms
64 bytes from 168.119.138.211: seq=3 ttl=54 time=254.112 ms
64 bytes from 168.119.138.211: seq=4 ttl=54 time=254.057 ms

--- downloads.openwrt.org ping statistics ---
5 packets transmitted, 5 packets received, 0% packet loss
round-trip min/avg/max = 253.897/254.697/257.262 ms

But trying to update the package list still results in an error:

Collected errors:
 * opkg_download: Failed to download https://downloads.openwrt.org/releases/22.03-SNAPSHOT/targets/mediatek/mt7622/packages/Packages.gz, wget returned 4.
 * opkg_download: Check your network settings and connectivity.

Then I noted if I ping downloads.openwrt.org from the ssh console it results in "nothing". Note how the ping through ssh attempts to ping an IPv6 address, I did not specify that:

root@OpenWrt:~# ping  downloads.openwrt.org
PING downloads.openwrt.org (2a01:4f8:251:321::2): 56 data bytes



Finally, pinging with the IPv6 address from the diagnositcs tab results in:

PING downloads.openwrt.org (2a01:4f8:251:321::2): 56 data bytes

--- downloads.openwrt.org ping statistics ---
5 packets transmitted, 0 packets received, 100% packet loss

Try disabling the wan6 network interface.

You also could potentially have an issue if your installed snapshot is out of date relative to the currently available one on the downloads site... but that will produce a different error, and your pings should still work.

I installed yesterday, so I guess the snapshot is recent.

I stopped the wan6 interface, and I could download the package list. So far so good. But now two older devices, (laptop or one of the phones, (both with 2.4GHz, if that matters)) do not get an Internet connection anymore from the Linksys. The browser shows:

DNS_PROBE_FINISHED_NO_INTERNET

Turning the wan6 network interface back on restores the Internet connection for the older devices. But it also stops the package updater working again.

You're double NATing, ideally you should set up the Linksys as a dumb AP.
The issues you're having should go away, in the process.

Thank you for that.

I read through the article you linked and it says, when turning it in a dump AP, the firewall function will be lost (among other things). This network is supposed to be a sort of guest network, so I would like to block some things eventually and make use of time switched parental controls. So, what be a good way to achieve that? Do I need a separate firewall? (There is no firewall on the modem)

1 Like

Does the ISP modem allow you to setup static routes. If so you can avoid using Double NAT.