Devices connected to LAN are offline after removing unused USB wifi antenna

EDIT: here is the /network config file. Radio2 is the new usb antenna, radio1 is the old.

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd6c:45df:6904::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth1'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option proto 'dhcp'
        option device 'eth0'

and the /wireless config file:

config wifi-device 'radio0'
        option type 'mac80211'
        option path 'platform/soc/fe300000.mmcnr/mmc_host/mmc1/mmc1:0001/mmc1:0001:1'
        option channel '36'
        option band '5g'
        option cell_density '0'
        option txpower '20'
        option htmode 'VHT80'
        option disabled '1'

config wifi-iface 'wifinet2'
        option device 'radio0'
        option mode 'ap'
        option ssid 'Miller5G'
        option key '7164728632'
        option network 'lan'
        option encryption 'psk2'
        option ieee80211r '1'
        option ft_over_ds '1'
        option ft_psk_generate_local '1'
        option disabled '1'

config wifi-device 'radio2'
        option type 'mac80211'
        option path 'scb/fd500000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0/usb1/1-1/1-1.2/1-1.2:1.0'
        option htmode 'HT20'
        option band '2g'
        option channel '1'
        option legacy_rates '1'
        option cell_density '0'

config wifi-iface 'default_radio2'
        option device 'radio2'
        option network 'lan'
        option mode 'ap'
        option wmm '0'
        option encryption 'psk2'
        option key '7164728632'
        option ieee80211r '1'
        option ft_over_ds '1'
        option ft_psk_generate_local '1'
        option ssid 'Miller'

config wifi-iface 'wifinet4'
        option device 'radio2'
        option mode 'mesh'
        option encryption 'none'
        option mesh_fwding '1'
        option mesh_rssi_threshold '0'
        option network 'lan'
        option mesh_id 'miller-mesh'

config wifi-device 'radio1'
        option type 'mac80211'
        option path 'scb/fd500000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0/usb1/1-1/1-1.1/1-1.1:1.0'
        option channel '1'
        option band '2g'
        option htmode 'HT20'
        option disabled '1'

I have a mesh system and I upgraded a USB wifi antenna. The configuration of the old one is moved to the new one and the old one is unused. This is plugged into the back of the main router (connected to modem). When I unplug the old unused antenna, I am unable to access the internet from all devices on the LAN (laptops, TVs, etc) and am unable to access LuCi and SSH into the main router until I reinsert the old antenna and reboot the router. However, I am able to SSH into and access LuCi for the second router while the main router is not working. I have not changed any of the configuration for the second router.

Without seeing your /etc/config/network it is difficult to be sure, but it sound like your device is re-enumerating the network interfaces when you remove this device, leading to the wrong devices being in your LAN or WAN group.

You can possibly get around this by removing the device config in Luci before pulling it out.

I have added the network config file in the question. Does this help?