Devices connected to a bridge interface can't ping each other, only the router

Hello everybody!

I'm struggling with something maybe simple, but after days of reading and trying various things, I haven't been able to figure it out on my own.

I'm building an x86 router with OpenWrt running in a VirtualBox VM hosted on Windows.

Connections:
eth0 - Host-only Ethernet adapter, connected to the mng (management) interface. (192.168.0.x)
eth1 - Ethernet card bridged with host, connected to the wan interface (PPPoE).
eth2 - USB Ethernet adapter bridged with host, connected to the LAN interface. (192.168.1.x)

The eth2 port is connected to an unmanaged switch with other equipment and 2 dumb APs also running OpenWrt.
The eth1 port is connected to the ISP modem

Everything is working very well.

I decided to add a third dumb AP, but my switch ran out of ports. So I added another USB to LAN adapter on the host machine, passing it through (not bridging) to the VM.
After installing the correct drivers and firmware, the eth3 came up nicely.

I created a br-lan bridge device and added eth2 and eth3 to the bridge ports.
So I replaced the lan interface with a new one with the br-lan bridge device.

All equipment connected to the switch (eth2) is working as before: they can see each other and everyone has an internet connection.

The problem:
Any equipment connected to the eth3 port gets the configuration provided by the DHCP server on the lan interface (IP range 192.168.1.x, subnet 255.255.255.0, gateway 192.168.1.1 and DNS address 192.168.1.10).
BUT they cannot see or ping those connected to the eth2 port, even though they have the same IP range and subnet. As a result, they are unable to connect to the Internet (local DNS 192.168.1.10)

Why does it happen?
I really can't understand why even though the eth2 and eth3 interfaces are bridged, the devices connected to them remain isolated.

I can ping devices connected to eth2 and eth3 from the router. But you can't ping each other.

What am I missing here?
Thank you very much!

Here are some of the configuration files:

ubus call system board:

{
        "kernel": "5.15.127",
        "hostname": "OpenWrt",
        "system": "Intel(R) Core(TM) i7-4790K CPU @ 4.00GHz",
        "model": "innotek GmbH VirtualBox",
        "board_name": "innotek-gmbh-virtualbox",
        "rootfs_type": "squashfs",
        "release": {
                "distribution": "OpenWrt",
                "version": "23.05.0-rc3",
                "revision": "r23389-5deed175a5",
                "target": "x86/64",
                "description": "OpenWrt 23.05.0-rc3 r23389-5deed175a5"
        }
}

cat /etc/config/network:

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd36:xxxx:xxxx::/48'

config interface 'wan'
        option device 'eth1'
        option proto 'pppoe'
        option username 'xxxx@xxxx'
        option password 'xxxx'
        option ipv6 'auto'

config interface 'mng'
        option proto 'static'
        option device 'eth0'
        option ipaddr '192.168.0.1'
        option netmask '255.255.255.0'

config device
        option type 'bridge'
        option name 'br-lan'
        list ports 'eth2'
        list ports 'eth3'

config interface 'lan'
        option proto 'static'
        option device 'br-lan'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option delegate '0'

cat /etc/config/dhcp:

config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option cachesize '1000'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
        option nonwildcard '1'
        option localservice '1'
        option ednspacket_max '1232'
        option filter_aaaa '0'
        option filter_a '0'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        list dhcp_option '6,192.168.1.10'

cat /etc/config/firewall:

config defaults
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option synflood_protect '1'

config zone
        option name 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        list network 'mng'
        list network 'lan'

config zone
        option name 'wan'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'
        list network 'wan'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-MLD'
        option src 'wan'
        option proto 'icmp'
        option src_ip 'fe80::/10'
        list icmp_type '130/0'
        list icmp_type '131/0'
        list icmp_type '132/0'
        list icmp_type '143/0'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-IPSec-ESP'
        option src 'wan'
        option dest 'lan'
        option proto 'esp'
        option target 'ACCEPT'

config rule
        option name 'Allow-ISAKMP'
        option src 'wan'
        option dest 'lan'
        option dest_port '500'
        option proto 'udp'
        option target 'ACCEPT'

opkg list-installed:

base-files - 1539-r23389-5deed175a5
bnx2-firmware - 20230804-1
busybox - 1.36.1-1
ca-bundle - 20230311-1
cgi-io - 2022-08-10-901b0f04-21
collectd - 5.12.0-49
collectd-mod-cpu - 5.12.0-49
collectd-mod-interface - 5.12.0-49
collectd-mod-iwinfo - 5.12.0-49
collectd-mod-load - 5.12.0-49
collectd-mod-memory - 5.12.0-49
collectd-mod-network - 5.12.0-49
collectd-mod-rrdtool - 5.12.0-49
dnsmasq - 2.89-4
dropbear - 2022.82-5
e2fsprogs - 1.47.0-2
ethtool-full - 6.3-1
firewall4 - 2023-03-23-04a06bd7-1
fstools - 2023-02-28-bfe882d5-1
fwtool - 2019-11-12-8f7fe925-1
getrandom - 2022-08-13-4c7b720b-2
grub2 - 2.06-5
grub2-bios-setup - 2.06-5
grub2-efi - 2.06-5
hostapd-common - 2023-09-08-e5ccbfc6-3
htop - 3.2.2-1
iperf3 - 3.15-1
iptables-mod-ipopt - 1.8.8-1
iptables-zz-legacy - 1.8.8-1
irqbalance - 1.9.2-2
iw - 5.19-1
iwinfo - 2023-07-01-ca79f641-1
iwlwifi-firmware-iwl7260 - 20230804-1
jansson4 - 2.14-3
jshn - 2023-05-23-75a3b870-1
jsonfilter - 2018-02-04-c7e938d6-1
kernel - 5.15.127-1-f12cad7e28a8d370c8c790636360fd31
kmod-amazon-ena - 5.15.127-1
kmod-amd-xgbe - 5.15.127-1
kmod-bnx2 - 5.15.127-1
kmod-button-hotplug - 5.15.127-3
kmod-cfg80211 - 5.15.127+6.1.24-3
kmod-crypto-acompress - 5.15.127-1
kmod-crypto-aead - 5.15.127-1
kmod-crypto-ccm - 5.15.127-1
kmod-crypto-cmac - 5.15.127-1
kmod-crypto-crc32c - 5.15.127-1
kmod-crypto-ctr - 5.15.127-1
kmod-crypto-gcm - 5.15.127-1
kmod-crypto-gf128 - 5.15.127-1
kmod-crypto-ghash - 5.15.127-1
kmod-crypto-hash - 5.15.127-1
kmod-crypto-hmac - 5.15.127-1
kmod-crypto-manager - 5.15.127-1
kmod-crypto-null - 5.15.127-1
kmod-crypto-rng - 5.15.127-1
kmod-crypto-seqiv - 5.15.127-1
kmod-crypto-sha256 - 5.15.127-1
kmod-crypto-sha512 - 5.15.127-1
kmod-e1000 - 5.15.127-1
kmod-e1000e - 5.15.127-1
kmod-forcedeth - 5.15.127-1
kmod-fs-vfat - 5.15.127-1
kmod-hwmon-core - 5.15.127-1
kmod-i2c-algo-bit - 5.15.127-1
kmod-i2c-core - 5.15.127-1
kmod-ifb - 5.15.127-1
kmod-igb - 5.15.127-1
kmod-igc - 5.15.127-1
kmod-input-core - 5.15.127-1
kmod-ipt-core - 5.15.127-1
kmod-ipt-ipopt - 5.15.127-1
kmod-iwlwifi - 5.15.127+6.1.24-3
kmod-ixgbe - 5.15.127-1
kmod-lib-crc-ccitt - 5.15.127-1
kmod-lib-crc32c - 5.15.127-1
kmod-lib-lzo - 5.15.127-1
kmod-libphy - 5.15.127-1
kmod-mac80211 - 5.15.127+6.1.24-3
kmod-mdio - 5.15.127-1
kmod-mdio-devres - 5.15.127-1
kmod-mii - 5.15.127-1
kmod-nf-conntrack - 5.15.127-1
kmod-nf-conntrack6 - 5.15.127-1
kmod-nf-flow - 5.15.127-1
kmod-nf-ipt - 5.15.127-1
kmod-nf-log - 5.15.127-1
kmod-nf-log6 - 5.15.127-1
kmod-nf-nat - 5.15.127-1
kmod-nf-reject - 5.15.127-1
kmod-nf-reject6 - 5.15.127-1
kmod-nfnetlink - 5.15.127-1
kmod-nft-core - 5.15.127-1
kmod-nft-fib - 5.15.127-1
kmod-nft-nat - 5.15.127-1
kmod-nft-offload - 5.15.127-1
kmod-nls-base - 5.15.127-1
kmod-nls-cp437 - 5.15.127-1
kmod-nls-iso8859-1 - 5.15.127-1
kmod-nls-utf8 - 5.15.127-1
kmod-phy-realtek - 5.15.127-1
kmod-ppp - 5.15.127-1
kmod-pppoe - 5.15.127-1
kmod-pppox - 5.15.127-1
kmod-pps - 5.15.127-1
kmod-ptp - 5.15.127-1
kmod-r8169 - 5.15.127-1
kmod-rt2800-lib - 5.15.127+6.1.24-3
kmod-rt2800-usb - 5.15.127+6.1.24-3
kmod-rt2x00-lib - 5.15.127+6.1.24-3
kmod-rt2x00-usb - 5.15.127+6.1.24-3
kmod-sched-cake - 5.15.127-1
kmod-sched-core - 5.15.127-1
kmod-scsi-core - 5.15.127-1
kmod-slhc - 5.15.127-1
kmod-tg3 - 5.15.127-1
kmod-usb-core - 5.15.127-1
kmod-usb-ehci - 5.15.127-1
kmod-usb-ledtrig-usbport - 5.15.127-1
kmod-usb-net - 5.15.127-1
kmod-usb-net-cdc-ether - 5.15.127-1
kmod-usb-net-cdc-ncm - 5.15.127-1
kmod-usb-net-rtl8152 - 5.15.127-1
kmod-usb-ohci - 5.15.127-1
kmod-usb-storage - 5.15.127-1
kmod-usb-storage-extras - 5.15.127-1
kmod-usb-storage-uas - 5.15.127-1
kmod-usb-uhci - 5.15.127-1
kmod-usb-xhci-hcd - 5.15.127-1
kmod-usb2 - 5.15.127-1
kmod-usb3 - 5.15.127-1
libatomic1 - 12.3.0-4
libblkid1 - 2.39-2
libblobmsg-json20230523 - 2023-05-23-75a3b870-1
libc - 1.2.4-4
libcomerr0 - 1.47.0-2
libevdev - 1.13.0-1
libext2fs2 - 1.47.0-2
libf2fs6 - 1.16.0-1
libgcc1 - 12.3.0-4
libical - 3.0.9-2
libip4tc2 - 1.8.8-1
libip6tc2 - 1.8.8-1
libiperf3 - 3.15-1
libiptext0 - 1.8.8-1
libiptext6-0 - 1.8.8-1
libiwinfo-data - 2023-07-01-ca79f641-1
libiwinfo20230701 - 2023-07-01-ca79f641-1
libjson-c5 - 0.16-3
libjson-script20230523 - 2023-05-23-75a3b870-1
libkmod - 30-1
libltdl7 - 2.4.7-1
liblua5.1.5 - 5.1.5-10
liblucihttp-ucode - 2023-03-15-9b5b683f-1
liblucihttp0 - 2023-03-15-9b5b683f-1
libmbedtls12 - 2.28.4-1
libmnl0 - 1.0.5-1
libncurses6 - 6.4-2
libnftnl11 - 1.2.6-1
libnl-tiny1 - 2023-07-27-bc92a280-1
libpci - 3.10.0-1
libpthread - 1.2.4-4
librrd1 - 1.0.50-5
librt - 1.2.4-4
libsmartcols1 - 2.39-2
libss2 - 1.47.0-2
libubox20230523 - 2023-05-23-75a3b870-1
libubus20220615 - 2022-06-15-9913aa61-1
libubus20230605 - 2023-06-05-f787c97b-1
libuci20130104 - 2023-08-10-5781664d-1
libuclient20201210 - 2023-04-13-007d9454-1
libucode20220812 - 2023-04-03-51638672-1
libudev-zero - 1.0.1-1
libusb-1.0-0 - 1.0.26-3
libustream-mbedtls20201210 - 2023-02-25-498f6e26-1
libuuid1 - 2.39-2
libwolfssl5.6.3.e624513f - 5.6.3-stable-1
libxtables12 - 1.8.8-1
logd - 2022-08-13-4c7b720b-2
luci - git-23.051.66410-a505bb1
luci-app-firewall - git-23.208.40260-9504081
luci-app-opkg - git-23.009.82915-ec3aac4
luci-app-sqm - git-22.360.73151-127c900
luci-app-statistics - git-23.184.27766-2c7b34b
luci-base - git-23.219.80063-bece581
luci-light - git-23.024.33244-34dee82
luci-mod-admin-full - git-19.253.48496-3f93650
luci-mod-network - git-23.218.31344-f74f1cb
luci-mod-status - git-23.210.72323-b6dc2f2
luci-mod-system - git-23.118.78765-58f7b27
luci-proto-ipv6 - git-21.148.48881-79947af
luci-proto-ppp - git-21.158.38888-88b9d84
luci-ssl - git-23.035.26083-7550ad6
luci-theme-bootstrap - git-23.085.34270-d94a728
mkf2fs - 1.16.0-1
mtd - 26
netifd - 2023-06-04-ec9dba72-1
nftables-json - 1.0.8-1
odhcp6c - 2023-05-12-bcd28363-20
odhcpd-ipv6only - 2023-06-24-52112643-1
openwrt-keyring - 2022-03-25-62471e69-2
opkg - 2022-02-24-d038e5b6-2
partx-utils - 2.39-2
pciids - 0.359-1
pciutils - 3.10.0-1
ppp - 2.4.9.git-2021-01-04-4
ppp-mod-pppoe - 2.4.9.git-2021-01-04-4
procd - 2023-06-25-2db83655-1
procd-seccomp - 2023-06-25-2db83655-1
procd-ujail - 2023-06-25-2db83655-1
px5g-mbedtls - 9
r8152-firmware - 20230804-1
r8169-firmware - 20230804-1
rpcd - 2023-07-01-c07ab2f9-1
rpcd-mod-file - 2023-07-01-c07ab2f9-1
rpcd-mod-iwinfo - 2023-07-01-c07ab2f9-1
rpcd-mod-luci - 20230123-1
rpcd-mod-rrdns - 20170710
rpcd-mod-ucode - 2023-07-01-c07ab2f9-1
rrdtool1 - 1.0.50-5
rt2800-usb-firmware - 20230804-1
sqm-scripts - 1.6.0-1
tc-tiny - 6.3.0-1
terminfo - 6.4-2
ubox - 2022-08-13-4c7b720b-2
ubus - 2022-06-15-9913aa61-1
ubusd - 2022-06-15-9913aa61-1
uci - 2023-08-10-5781664d-1
uclient-fetch - 2023-04-13-007d9454-1
ucode - 2023-04-03-51638672-1
ucode-mod-fs - 2023-04-03-51638672-1
ucode-mod-html - 1
ucode-mod-math - 2023-04-03-51638672-1
ucode-mod-nl80211 - 2023-06-06-c7d84aae-1
ucode-mod-rtnl - 2023-06-06-c7d84aae-1
ucode-mod-ubus - 2023-04-03-51638672-1
ucode-mod-uci - 2023-04-03-51638672-1
ucode-mod-uloop - 2023-06-06-c7d84aae-1
uhttpd - 2023-06-25-34a8a74d-1
uhttpd-mod-ubus - 2023-06-25-34a8a74d-1
urandom-seed - 3
urngd - 2020-01-21-c7f7b6b6-1
usbutils - 014-1
usign - 2020-05-23-f1f65026-1
wireless-regdb - 2023.05.03-1
wpad-wolfssl - 2023-09-08-e5ccbfc6-3
xtables-legacy - 1.8.8-1
zlib - 1.2.13-1