Device upgraded from 19.x to 21.x loses settings on every restart


I'm fighting since over an hour with a device here (tp-link cpe210). I flashed a sysupgrade over luci (from 19.x to 21.02.2) with "keeping settings" enabled.

After upgrade I lost control over the device (was configured as a dumb AP) so I teared it down and entered failsafe directly wired to my client. I put firstboot in the ssh console while in failsafe and then rebooted.

The device showed 21.02.2 and was on it's default setting. So far so good.

But then I configured it be used as a dumb AP but when I power cycled the device it reverted the settings back (even saved & applied successfully before!)

I then did it again, set it all up saved & applied settings with success and used restart in luci :boom: back on default! Why? :cry:

Did it a third time now:

Powered by LuCI openwrt-21.02 branch (git-22.046.85957-59c3392) / OpenWrt 21.02.2 r16495-bf0c965af0

All settings saved & applied:

And after restart it just comes back with defaults, dhcp enabled, restored wan interfaces etc.:

Why :question:

The flash could be full. That device only has 8 MB and more than usual is set aside for OEM partitions (384K) Are you trying to install any packages?

On the clean firstboot, before changing anything, check the free space under System--Software. If it shows a remarkably large amount (half of the RAM, or about 30 MB), the overlay has been mounted on RAM due to a problem with the flash.

1 Like

Actually I did the same now on my second unit and it behave exactly the same. I quite sure it's no hardware fault, the units provided the area with wifi till I took them down 2 hours ago....

Many of my device only have 4MB actually :grimacing:

no packages installed. I really just wanted to configure the freshly upgraded and to defaults reset device to act (again) as a dumb AP.

It all worked flawlessly with 19.x on both units - now both units kill my fireabend :frowning_face:

When I entered the failsafe I did this:

root@(none):~# firstboot && reboot now
This will erase all settings and remove any installed packages. Are you sure? [N/y]
/dev/mtdblock6 is not mounted
/dev/mtdblock6 will be erased on next mount

Anything I can check if flash is working normally or anything else?

make sure you installed the correct file
this maybe due to installing the initramfs file
as it's meant for ram only it will not save to flash
make sure you flashed the squashfs-factory.bin

1 Like

I flashed openwrt-21.02.2-ath79-generic-tplink_cpe210-v1-squashfs-sysupgrade.bin via luci (openwrt 19.x) and even compared the sha256 sum's after uploading. It was all correct and plausible

When I try to downgrade to openwrt 19.x again (from 20.02 luci) I get this message:

not sure if something changed in the newer version or if this indicates I have broken installation or something. Actually it's indicating it could be just because I want to downgrade....

Back on openwrt 19.x and the device is able to save settings again

more free flash despite both binaries 19.07.9 and 21.02.2 are both 7,8MB in size....

Upgrade to 21.02.2 again and the amnesia is gone :whale:

Also now that I flashed with my client directly connected to the device it also rendered the device unusable again (like when it was remotely installed) and I needed to activate failsafe and do a firstboot to "recover" it into a working state.

But why?

Make sure to uncheck the "Keep settings" box any time you change between 19 and 21 in either direction. The settings can't be transferred, you will need to configure the new install from scratch.


Now that I have my first of the two units working I just downgraded the second one from 21 to 19 without unchecking that box.

Now there is only the power led on and all others don't do nothing (the flicker when booting etc.). I also can't access the device anymore, failsafe doesn't work ether...

So do I have a bricked unit now? :sob:

Yes if the LED doesn't blink in the OpenWrt pattern when booting, it is bricked. You've probably done something like force in a factory image where sysupgrade was called for. The OpenWrt kernel isn't starting at all, so a bootloader based method like TFTP recovery will be necessary.

1 Like

You can see if TP-Link CPE210/CPE220 Debricking / Restore stock firmware (webrevert) helps.

1 Like

Lucky me, had it plugged in now for a long time and suddenly it showed the eth0 led and actually works. So now from 19.x again to 21.02.2.

Actually what I did before it magically came back was to keep the reset pin holding for more than 12 seconds when plugging in power. I remember the former owner told to do than before I could set up the devices initially.

due to the change of systems from ar71xx to ath79 thing are not the same as normal for these devices
the next thing I would try is to flash the factory image via your routers recommended recovery method;a=commit;h=08857e69becc214336ba073bca6f626bfaa67781

I had this problem also when going from a 21.02.x to another 21.02.x snapshot, and eventually realised the problem was due to the fact that every new flash alternates between data partitions for settings. So when I went from 19.x to 21.x I took everyone's advice to not keep settings, that was successful.
But when a few weeks after trying another snapshot, I ticked the keep settings, which effectively copies current settings across to other data partition which was still formatted for the old 19 x system, and something about the formatting (compression from memory) is not compiled into the new kernel (as seen with dmesg looking at in early stages of mounting data overlay partition), so it cannot mount that partition any more.
The solution was to flip back to the previously loaded snapshot and take a backup and choose option not to keep settings which will do a format of the new data partition, or work out which mtd is the second partition and kill the formatting on it so it can be rebuilt properly on first boot after the flash (Linksys WRT1900ACSv2 fyi).

@Lucky1 @tonymy01

It looks like downgrading to the latest 19.x release (19.07.9) from 21.02.2 and then up to 21.02.2 (without keeping settings) again solved all the the issues regarding amnesia.

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.