Device sees internet and Luci responds but can't connect to google and 2.4g shows active but not 5g and WiFi drops

Hello, As per headline, this is a factory install on a Linksys 1900AC V1.

I have a ISP fiber modem it has no user functionality other than a power switch. I also removed my ISP Netis WF2780 router which works great, but, I want the power and functionality of LEDE on Linksys. I want the Linksys to be my primary router.
I want to retain: Fiber Modem -» Linksys LEDE Router -» my lan devices.

I want to have my lan clients protected by router based VPN.
I want to eventually add smart home functionality in the future.
The 2 digital TV's I have -one is smart, the other just an early model internet friendly TV- are RJ45 cabled but WiFi/Google Home usually works well enough.
I want to " jailbreak " them from regional blocks to watch global TV via VPN too.

So, faultless install, but the cable and WiFi internet just won't work beyond brief uptime, like a minute or two, although the LEDs are on. Note that this same problem existed BEFORE on the Linksys, when it had just been refurbished with the latest OEM firmware, I had previously recovered it after a storm power surge rendered it bricked.
It also has a loud fan on startup that goes away after several minutes. I mention this as it may be "mechanical" rather than firmware, but I suspect a faulty component would be far more devastating, so I think there's some ISP end incompatibility?

Check to see if your LAN and WAN ports are in the same address range.

They are not, but there is no 'solution' in the documentation. It only says:

" * If these two addresses are in the same range, e.g., if they start with the same three sets of numbers, then they are in the same address range. You need to change the address of the LAN interface (see next step)."

So I did this anyway, and rebooted into

"* If the address ranges do not conflict, then ask on the [OpenWrt Forum]"

They DO conflict, so how to change them? They look like 10.XX.XX.XXX

Also read a very complicated document on here about IPV4 and NAT and I think this may be part of the problem, but really hope it is not because the fixes seem either very complex, or seem to defeat the point of OpenWRT. also I don't game, so everything should work like before. But it's possible I'm just confused at this point with new info overload.
I also saw a solution on reddit that's 3 years old where someone said PPOE needs to be set up but they didn't elaborate.

I hope all this info helps you to help me. Thanks.

10.x.x.x. does not conflict with 192.168.2.x

The document in the same paragraph dealing with conflicts, said the IP of WAN & LAN should be groups of three digits, I see two. XX.XX.etc what else am I to infer from that?
I understand a conflict in the sense of two identical IPs
So can you elaborate on why they specify "groups of three" also, I don't ever recall seeing an IP rendered as two by two. Thanks for the reply.

Hi mbo2o, I am still getting used to how this thread is tiered, I messed up my first reply quoting my entire OP. So to quote the document:" If these two addresses are in the same range, e.g., if they start with the same three sets of numbers, then they are in the same address range"

1 Like

The quoted article is referring to the 192.168.1 portion of the IP, that's the "network" portion and the final number is the "host" portion.

I'm not sure what your device is seeing on the network, can you maybe post a screenshot of the overview page in Luci?

Also going back to

This seems sketchy, as there may well be something physically wrong here that new software won't help

1 Like

One more question. Does the ISP offer DHCP or do you have to run PPPOE to connect?
Have you set it up properly as it was on Netis WF2780?

Not working like you would expect with stock firmware usually means there is a hardware failure.

I suggest going back to your original router for the connection to the fiber modem. Then set up your 1900 for a simple test as double NATting and wifi AP with stock firmware. If it keeps disconnecting / crashing even at that, the hardware is likely bad. You should try a different power supply though before saying the router is dead.


Apologies for rhe late response. It runs on DCHP, also, the Netis never was set with any firmware other than stock.
Edit: Also if you mean is the Linksys configured to the same perameters as the Netis, well I think so, but I'm also on a learning curve, Ill try to capture and post some logs, it may revaeal issues I sont even know to look for.
Also, I apologize in advance, but I can't always focus on this issue, its one of one of many, lol, I'm also trying to fix a Linux upgrade failure, and replace the sealed battery on my main Android device, then root that too! My final goal with the router is VPN on my home network, all of this is like being my own full time tech support team.

Thanks. I will try exchange the power supply first, as going back to stock firmware, for me at least, seems an unecessary brick risk, and also, if the problem replicates over two firmwares, then I can't see the point of this excercise UNLESS the power supply is at fault, in which case reverting to stock would be redundant. Or have I missed/misunderstood the rationale in your double NAT suggestion?

He means to connect the Netis router on the fibre modem and then connect the 1900 on the Netis. So the Netis will do first NAT and the 1900 will do the second NAT, hence the double NAT.

Yes, but going back to the central issue, whereby two firmwares display identical erraric connectivity, what would this setup confirm - that the powersupply could be eliminated as the problem? I'm still a bit confused as to the rationale, not the practicality of the rig.

Edit: OK I re-read the first comment s-l-o-w-l-y and I get it now. Thanks all.

On reddit, other ACS1900 users report similar. Maybe the power surge and drop out issue are coincidental?
I am very reluctant to do the double NAT test. For one, I am extremely time poor. I will flash.another version Davidc502 build, available here, and if that's not working, then, I'm going to buy a new router, that I KNOW will work with Open VPN and also change my VPN provider to one that is router friendly. I use Private Internet Access, and they have notoriously poor VPN -thru -router support. Wasn't an issue when I signed up tho.

An update.
It wasn't the power supply.
It wasn't even the router.
We had a number of issues.
The ISP guys renovated the RS Ethernet cable connectors.
Some banana tree fronds were tangled in the external fiber cable, disrupting services in windy conditions.
Finally, a new 'modem'? was connected to the fiber terminal box (they still don't seem to have all in ones here) to allow the Ethernet cable to access the router, they kindly configured the WRT1900AC V1,which is running Open WRT, but now I can't login to Luci to do a the things I have struggled for these months. (it's rejecting the browser recorded password?) WTF!#!! and can't use the failsafe mode because my version of David 502s build does not have squashfs , unless anyone has a work around I have to reset and lose the router config two ISP guys struggled with for an hour, GREAT!

Caps Lock, different layout, different language, try different browser, clean cache.
Also try with SSH, if you have enabled ssh-key logins that could let you in without remembering the password.

1 Like

Thanks again trendy.
I did all those housekeeping tasks, power cycled everything.
I was incorrect about not having squashfs, in part because of the way it was described to check in the terminal/console for it, which of course, is a badly written instruction!
I finally checked this David402c builds on here, and still have the original pkg on my home screen. So I do have squashfs.
So I'm trying to decipher the terribly written instructions on this site. I do appreciate the original author sharing knowledge, except instructions are limited to 'press a button' (once you powercycle the router). I figured out this may be the router reset button. Maybe...
All I want to do is get into my console, reset the password, set up a home network VPN, and hook up an external hard drive with movies on it (Basic 'two minute tek' anywhere else, but I'm sure that will be a fabulous night of nights as well!)
Sorry about the rant, but it seems the entire site has been translated badly from another language?
I can access iterm2 (terminal app for Mac)
Are there clear, instructions anywhere on how to proceed or must I play powercycle roulette to get in? I still have no idea how that actually works, it is that badly written.
I'm marking this as solved, because the initial problem of the connection dropping has been solved by a ISP tech visit. I will purse accessing Luci via terminal commands by RTFF, and fingers crossed.

but now I can't login to Luci to do a the things I have struggled for these months. (it's rejecting the browser recorded password?)

Are you using Chrome by chance? I've found that when certain changes (seems to be mainly in network) are made in Luci with Chrome it 'updates' the saved router password with the wifi password or some other entry that was made, you might try just entering the password manually and see if that lets you in, if it does you'll be asked if you want to update the password so just click yes and it should be back to normal.


FF does the same actually.


Thanks mike. I've tried that. I also had duck-go browser layered on chrome, webroot antivirus, and VPN all disabled.
Cache cleared. etc.
I did find how to invoke ssh from bash but I get password denied and then ssh revert to bash thinking I'm an intruder.
I do remember getting the checksum 'warning' I responded 'yes' and it immediately asked for the password, at that point I should have seen a login/welcome message on ssh terminal, am I correct?
It looks like a reset is the only way, I'm dreading it, back to months of pain, I fear.

You can use safe mode, then mount the overlay file system, then reset the root password, then take a backup of the config.

Here's the official failsafe mode stuff:

1 Like

Yes I am at this point. The thing is, I cannot access failsafe in LuCi or ssh/terminal modes.
Because in both cases the known password is denied. I also wrote the password down, and logged in and out of LuCi a few times prior. (February) I then disconnected the router until the ISP guys visited for unrelated issues yesterday. They got it to work perfectly with everything, but I'm locked out now. It's possible they reset the password, but surely to do so they would have had to know my password to begin with, so that makes no sense. Unless they have a tool that can see into the router from the network end?
The only other possibility is that the stock.firmware password somehow got transposed, but that's a bit farfetched, no?