Device not getting global ipv6 when using PPOE in NDP Proxy mode {odhcpd[1859]: Failed to send to wan@pppoe-wan (Bad file descriptor)}

Hello,
I have set up my wan to ndp proxy mode and almost all other devices are working properly and getting the ipv6.

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fddd::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option device 'wan'
        option proto 'pppoe'
        option username '******'
        option password '******'
        option ipv6 '1'
        option delegate '0'

config interface 'WAN6'
        option proto 'dhcpv6'
        option device '@wan'
        option reqaddress 'try'
        option reqprefix 'auto'

config dnsmasq
        option domainneeded '1'
        option localise_queries '1'
        option rebind_protection '0'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option cachesize '1000'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
        option localservice '1'
        option ednspacket_max '1232'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv4 'server'
        option dhcpv6 'relay'
        option ra 'relay'
        option ndp 'relay'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

config dhcp 'WAN6'
        option interface 'WAN6'
        option ignore '1'
        option master '1'
        option ra 'relay'
        option dhcpv6 'relay'
        option ndp 'relay'

But only on my Main desktop device for some reason, NDP proxy is not working. It is getting a link-local address, not the main global one.

In the desktop ipconfig, global ipv6 is properly assigned
but in the openwrt ipv6 routes there is no entry for that ipv6 address

Any idea what could be the reason?

daemon.err odhcpd[1859]: Failed to send to 2404:4e40:7:198:9ffb:dd32:1c9b:3ad7%WAN6@pppoe-wan (Bad file descriptor)

Ok, from log it seems the ip is having some kind of error in odhcpd. Not sure what to do in this scenerio. But the ip that is assigned in ip config is save as it is in here

I think the issue is related to this github issue.
[odhcpd] IPv6 relay error: cannot discover LAN device, Bad file descriptor sending to wan@pppoe-wan · Issue #11599 · openwrt/openwrt (github.com)