Device does not resolve Host for WIFI connection

Hi friends, on my router AR750s ext. with OpenWrt 21.02 firmware (see attached photo) I can not associate my Neato Botvac robot with WIFI detection.
As you can see from the attached photo it detects the MAC ADDRESS but fails to resolve the host.
What could be the causes since all other devices pair seamlessly and fix the host?

Host names for DHCP clients are announced by the clients themselves, and it is an optional feature; perhaps your robot is not announcing any name, or perhaps there is a reason why the DHCP server is rejecting it.

You can try to debug the issue, or you can just assign a static IP address and name for that device, on the DHCP server (which is what I would recommend for any device that has to be reachable).

thanks for answering, on the router I use STATIC IP the DHCP service is disabled.

I still can not associate the device to the WIFI on my router openwrt, I do not understand why I can not read the name HOST

An easy workaround:
Change 11:22:33:44:55:66 to the real device's mac address and the "hostname" to whatever you want.

echo -e '11:22:33:44:55:66\thostname' >> /etc/ethers
1 Like

unfortunately the device "Neato Botvac" can not associate despite having entered the command above

Is the problem that it cannot associate (i.e. it can't actually join the wifi network), or that the hostname doesn't resolve? These are two different issues -- your title "Device does not resolve Host for WIFI connection" suggests it is a hostname issue, but the most recent statement above seems to indicate that you cannot get it on the network at all.

Actually it is just as I described because the robot has a virtual network card that inherits the access credentials from the physical network card of the router and transfers them to the NEATO ROBOT.
From the moment the router fails to resolve the host the pairing stops.

Sorry, I can't help in other languages (I wish I could). Please translate this to English.

1 Like

i'm sorry i have edit

1 Like

I'm not sure I follow the "virtual network card that inherits the access credentials from the physical network card of the router" -- can you describe this process? And are you really sure that this is a hostname issue? Frequently, these types of IoT devices don't have a way to set static IP addresses and you said that you have disabled DHCP on your router. It would not surprise me if the issue is simply that the robot establishes the wifi connection and then drops off when it cannot get an IP address. [I don't have a NEATO ROBOT device, so I could be totally wrong here, but a theory to investigate].

then the robot has an APP for managing it, once from the tablet you connect to the 2.4G network of the router, through the APP INSTALLED on the tablet you will establish the connection of the network card of the NEATO ROBOT by selecting the 2.4G network and entering the relative password.

the robot cannot get an IP address from the router probably, in turn the router cannot resolve the HOST name of the robot.

I'm going to guess that the robot requires an IP via DHCP. And you said earlier that the DHCP server is disabled on the router. Therefore, the robot cannot get an IP from the router by definition. This means that the robot cannot function on the network. Beyond that... as stated earlier:

The hostname will be probably be populated based on the DHCP process, but without a DHCP server, there's nothing to announce. Yes, maybe you could get a hostname to map to the MAC based on editing your ethers file or other techniques, but since the device can't function on the network due to no IP, it probably won't show up anyway.

Try turning on the DHCP server and see if it fixes the issue. Be sure that your static IP addresses do not overlap the DHCP pool.

Does the robot connect to the router at all?
Does it connect to the tablet, or does the tablet connect to the robot?

You didn't paste the command properly. There is a \t between the mac and the hostname which adds a tabspace in the entry. Edit the /etc/ethers and replace the \ with a tabspace.

2 Likes

Thanks for your patience, I made the correction and I also replaced the Host name with a STATIC IP address.
The result unfortunately remains negative because although this time is the MAC ADDRESS and the IP are seen by the router the neato robot can not connect its network card.
I don't know what to do anymore...!

Have you tried enabling the DHCP server? Although I don't have one of these devices, I have a hunch that they do not support manual IP address configuration -- they almost certainly rely on DHCP. An IP address for the device that is configured within the router will not have any effect unless the DHCP server is enabled (for this, you want to use the DHCP 'static leases' feature). If DHCP is not enabled, there is no mechanism for the NEATO device to have the address assigned to it (unless it does have a way of manually entering the IP address info using the device or app, which again, I think is unlikely to be exposed/supported).

1 Like

Yes, I think so too, can I only enable DHCP for the 2.4G network and leave the 5G configuration static?

Then I put uncomment on /etc/ethers on the line where I manually set the IP address to be assigned to the robot.

After I tried to configure the DHCP like this, I don't know if something is still missing?

DHCP is enabled on the network level, not the physical interface. If you have unique networks/subnets setup for your 5G and 2G radios (this is not necessarily the same as having different wifi network names), you can enable DHCP on one network and not the other. But if the 2G and 5G radios are linked to a common network (LAN), it is either all or none.

Is there a reason you are so reluctant to enable DHCP?

Let's see your config files:

Please copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall
1 Like
root@OpenWrt:/etc# cat /etc/config/network

config interface 'loopback'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'
        option device 'lo'

config globals 'globals'
        option ula_prefix 'fd1xxxxxxxx`Preformatted text`7:4af7::/48'

config interface 'lan'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.8.1'
        option gateway '192.168.1.1'
        option broadcast '192.168.8.255'
        option stp '1'
        option device 'br-lan'
        list dns '1.1.1.1'
        list dns '1.0.0.1'

config interface 'wan'
        option proto 'static'
        option netmask '255.255.255.0'
        option ipaddr '192.168.1.100'
        option gateway '192.168.1.1'
        option broadcast '192.168.1.255'
        option device 'eth0.2'
        option type 'bridge'
        list dns '1.1.1.1'
        list dns '1.0.0.1'

config interface 'wan6'
        option proto 'dhcpv6'
        option device 'eth0.2'
        option type 'bridge'

config switch
        option name 'switch0'
        option reset '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0t 2 3'
        option vid '1'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '0t 1'
        option vid '2'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0.1'

config interface 'wwan'
        option proto 'dhcp'
root@OpenWrt:/etc# cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11a'
        option path 'pci0000:00/0000:00:00.0'
        option cell_density '0'
        option channel '36'
        option htmode 'HT40'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option mode 'ap'
        option key 'xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx'
        option encryption 'psk2'
        option network 'lan'
        option ssid 'xxxxxxxxxxxxx'
        option macfilter 'allow'
        list maclist 'xxxxxxxxxxxx'
        list maclist 'xxxxxxxxxxxxxx'
        list maclist 'xxxxxxxxxxx'
        list maclist 'xxxxxxxxxxxxx'
        option ieee80211w '1'

config wifi-device 'radio1'
        option type 'mac80211'
        option hwmode '11g'
        option channel 'auto'
        option path 'platform/ahb/18100000.wmac'
        option cell_density '0'
        option htmode 'HT40'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option encryption 'psk2'
        option ssid 'xxxxxxxxxxx2.4'
        option key 'xxxxxxxxxxx
root@OpenWrt:/etc# cat /etc/config/dhcp

config dnsmasq
        option domainneeded '1'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option authoritative '1'
        option leasefile '/tmp/dhcp.leases'
        option localservice '1'
        option noresolv '1'
        option confdir '/tmp/dnsmasq.d'
        list server '127.0.0.1#5253'
        list server '/pool.ntp.org/8.8.8.8'
        option readethers '1'

config dhcp 'lan'
        option interface 'lan'
        option dhcpv6 'server'
        option ra 'server'
        option ra_management '1'
        option ignore '1'
        option start '100'
        option limit '150'
        option leasetime '12h'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'
        option start '100'
        option limit '150'
        option leasetime '12h'
        list ra_flags 'none'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

config domain
        option name 'xxxxxxxxxx'
        option ip '192.168.8.8'

root@OpenWrt:/etc# cat /etc/config/firewall

config defaults
        option output 'ACCEPT'
        option synflood_protect '1'
        option drop_invalid '1'
        option input 'REJECT'
        option forward 'REJECT'

config zone
        option name 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option masq '1'
        option forward 'REJECT'
        list network 'lan'

config zone
        option name 'wan'
        option output 'ACCEPT'
        option mtu_fix '1'
        option input 'REJECT'
        option forward 'REJECT'
        option masq '1'
        list network 'wan'
        list network 'wan6'
        list network 'wwan'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'
        option enabled '0'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option src_ip 'fc00::/6'
        option dest_ip 'fc00::/6'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'
        option enabled '0'

config rule
        option name 'Allow-MLD'
        option src 'wan'
        option proto 'icmp'
        option src_ip 'fe80::/10'
        list icmp_type '130/0'
        list icmp_type '131/0'
        list icmp_type '132/0'
        list icmp_type '143/0'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-IPSec-ESP'
        option src 'wan'
        option dest 'lan'
        option proto 'esp'
        option target 'ACCEPT'

config rule
        option name 'Allow-ISAKMP'
        option src 'wan'
        option dest 'lan'
        option dest_port '500'
        option proto 'udp'
        option target 'ACCEPT'

config include
        option path '/etc/firewall.user'

config redirect
        option dest_port '80'
        option src 'wan'
        option name 'Porta 80'
        option src_dport '80'
        option target 'DNAT'
        option dest 'lan'
        option dest_ip '192.168.8.124'

config redirect
        option dest_port '443'
        option src 'wan'
        option name 'Porta 443'
        option src_dport '443'
        option target 'DNAT'
        option dest 'lan'
        option dest_ip '192.168.8.124'