/dev/input not appearing on my OpenWrt 22.03.3 installation

I've been pulling my hair to get the /dev/input/* tree to appear when hotplugging a keyboard or mouse, but unfortunately I am not succeeding at all. > The directory /dev/input is not showing up :frowning:
I'm running OpenWrt 22.03.3 on GL.iNet GL-AR150, but have tried previous OpenWrt versions as well as 22.03.0, too.
I've also tried attaching different USB devices as well as installing any kmod-* module that made sense to me.
Is there something obvious that I'm missing or are there any configuration settings I have to make?

Any help is very largely appreciated! Thanks!

That would be a udev feature, but OpenWrt doesn't use udev.

1 Like

But shouldn't OpenWrt support /dev/input, too !?
I found examples here: http://h-wrt.com/en/doc/kb
.. and here: http://h-wrt.com/en/doc/kb

Dont know what I had done wrong before but after running ...

opkg update && opkg install kmod-usb-hid && reboot

... a hotplugged USB keyboard led to the creation of an entry below /dev/input/. Checked it by running ...

while sleep 1; do ls /dev/input/* ; done

... while plugging in the keyboard. Thanks!

(BTW: The package kmod-usb-hid was available on OpenWrt 22.03, but not on OpenWrt 19.07)

What is it that you are trying to achieve with this script? sleep is a command, not a logical test, so it doesn't belong in the while line like that.