Deutsche Telekom VDSL on FRITZ!Box WLAN 3370 not working

I have successfully installed OpenWRT 21.02.1 on a FRITZ!Box WLAN 3370 (Hynix image). However, the WAN connection will not come up. My ISP is Deutsche Telekom, I used "dsl0.7" as my WAN interface name. Internet access using the same line and same OpenWRT version and identical configuration (as far as I can tell) is working fine with a BT HomeHub 5a. I did even try a different FRITZ!Box WLAN 3370 with the same result. LuCI tells me "Network device is not present" in Network -> Interfaces (WAN section). One thing I have noticed is that the "WAN" port is not listed in the switch overview page in LuCI (it is listed on the HomeHub).

Here is my network configuration:

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fde2:239a:f88b::/48'

config atm-bridge 'atm'
        option vpi '1'
        option vci '32'
        option encaps 'llc'
        option payload 'bridged'
        option nameprefix 'dsl'

config dsl 'dsl'
        option ds_snr_offset '0'
        option firmware '/lib/firmware/vr9-B-dsl.bin'
        option annex 'b'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0.1'

config device
        option name 'eth0.1'
        option macaddr 'BC:05:43:EC:0D:23'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config device
        option name 'dsl0'
        option macaddr 'BC:05:43:ec:0d:26'

config interface 'wan'
        option proto 'pppoe'
        option ipv6 '1'
        option device 'dsl0.7'
        option username 'xxx@t-online.de'
        option password 'xxx'

config interface 'wan6'
        option device '@wan'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 4 6t'

(Not using a vectoring firmware does not make a difference.)

This is what the DSL status information looks like most of the time:

Line State: Silent
Line Mode: -
Line Uptime: 0h 0m 0s
Annex: -
Data Rate: 0 b/s / 0 b/s
Max. Attainable Data Rate (ATTNDR): 0 b/s / 0 b/s
Latency: 0.00 ms / 0.00 ms
Line Attenuation (LATN): 0.0 dB / 0.0 dB
Signal Attenuation (SATN): 0.0 dB / 0.0 dB
Noise Margin (SNR): 0.0 dB / 0.0 dB
Aggregate Transmit Power (ACTATP): 0.0 dB / 0.0 dB
Forward Error Correction Seconds (FECS): 0 / 0
Errored seconds (ES): 0 / 0
Severely Errored Seconds (SES): 0 / 0
Loss of Signal Seconds (LOSS): 0 / 0
Unavailable Seconds (UAS): 51524002 / 51524001
Header Error Code Errors (HEC): 0 / 0
Non Pre-emptive CRC errors (CRC_P): 0 / 0
Pre-emptive CRC errors (CRCP_P): 0 / 0
Power Management Mode: L3 - No power

It seems to try to establish a connection: DSL LED is flashing, status is briefly "Handshake" or "Full init", but never succeeds.

Using the OEM firmware, internet access is working without issues.

Just a suggestion. Does your 3370 work with OpenWrt 19.07 ?

If yes, then try sysupgrade to 21.02.x.

Also, do you need to specify the tone setting if you are using VDSL ?

config dsl 'dsl'
 option annex 'b'
 option tone 'b'
 option line_mode 'vdsl'
 option xfer_mode 'ptm'
 option ds_snr_offset '0' # OpenWrt 18 or later.

ps. the 3370 does not possess a separate WAN ethernet port, unlike HH5a, hence why the switch configuration menu in LuCI does not show the 5th ethernet port on 3370.

2 Likes

Try using wan as the interface name.

The status information on 19.07.08 looks somewhat different, but it conveys the same failure:

ATU-C Vendor ID:                          
ATU-C System Vendor ID:                   
Chipset:                                  Lantiq-VRX200
Firmware Version:                         5.7.9.9.0.6
API Version:                              4.17.18.6
XTSE Capabilities:                        , , , , , , , 
Annex:                                    
Line Mode:                                
Profile:                                  
Line State:                               DOWN [0x200: silent]
Forward Error Correction Seconds (FECS):  Near: 0 / Far: 0
Errored seconds (ES):                     Near: 0 / Far: 0
Severely Errored Seconds (SES):           Near: 0 / Far: 0
Loss of Signal Seconds (LOSS):            Near: 0 / Far: 0
Unavailable Seconds (UAS):                Near: 64 / Far: 62
Header Error Code Errors (HEC):           Near: 0 / Far: 0
Non Pre-emtive CRC errors (CRC_P):        Near: 0 / Far: 0
Pre-emtive CRC errors (CRCP_P):           Near: 0 / Far: 0
Power Management Mode:                    L3 - No power
Latency [Interleave Delay]:               0.0 ms [Fast]   0.0 ms [Fast]
Data Rate:                                Down: 0 b/s / Up: 0 b/s
Line Attenuation (LATN):                  Down: 0.0 dB / Up: 0.0 dB
Signal Attenuation (SATN):                Down: 0.0 dB / Up: 0.0 dB
Noise Margin (SNR):                       Down: 0.0 dB / Up: 0.0 dB
Aggregate Transmit Power (ACTATP):        Down: 0.0 dB / Up: 0.0 dB
Max. Attainable Data Rate (ATTNDR):       Down: 0 b/s / Up: 0 b/s
Line Uptime Seconds:                      0
Line Uptime:                              down

I tried different tone settings and encapsulation modes -- to no avail (also, it works on my HH5a when everything is left on auto).

Changing the interface name to "wan" did not help things either.

Usually in these cases I would suspect a faulty hardware or faulty cable setup, but, as I said, the OEM firmware very reliably establishes an internet connection (on both devices I own).

Have you flashed the 3370 back to OEM firmware to confirm VDSL is functioning?

I presume you have tried a different DSL cable, and checked the RJ11 socket is not damaged.

fwiw, apart from trying LEDE 17 with interface name 'ptm0.7', I can't think what else to suggest.

Yes, I flashed it back using that strange Windows-only recovery tool by AVM and it works nicely.

I'll try LEDE...

I found this link in google. Read the comments at the end, where someone has encountered the same issue with no sync. Solution is to use a different blob.

https://blog.michael.kuron-germany.de/2018/12/openwrt-on-avm-fritzbox-3370/

Is it possible the 3rd party blob you used in first post is not compatible?

(I believe the Lantiq blob used in 21.02 is identical to the one used in 17.01)

It's actually the one from the 3370 firmware. But others don't seem to work either. Also, in my experience, the blob included in OpenWRT works but without vectoring (it syncs with a max speed of 20 mbit/s)

EDIT: LEDE doesn't even boot :confused:

Same experience here. Non-Vectoring-capable VDSL2-modems will be forced to use a Profile that only uses the sub-carriers up to ~2.2MHz as these are exempted from vectoring so that ISPs do not need to replace old vectoring-incompatible ADSL-modems out in the field. But it will still use VDSL2/PTM and will not fall-back to ADSL....