Dependencies not picked up when PKG_NAME and Package/name differ

Hi. I'm having difficulties building few packages which include version string in their name, eg. libusb where:



define Package/libusb-1.0
  TITLE:=A library for accessing Linux USB devices
  DEPENDS:=+libpthread +librt

Packages get built just fine, but I get an error message about missing dependencies, eg:

Package libusb-1.0 is missing dependencies for the following libraries:

Since I got no errors on other packages, which have the same PKG_NAME and Package/name, I tried building with that -1.0 removed at the end, and libusb didn't complain about missing depency. If someone could point me to right direction where to fix this issue, that would be sweet. I'm using quite old toolchain, uClibc-1.0.14 with gcc 5.5.0 for arm and I can't update those at the moment. Other than that, I shouldn't be far behind the master tree.

I tried fiddling with include/ but that didn't seem to have any effect. The staging_dir/[target]/pkginfo/libusb-1.0.provides file doesn't include libthread, only default libraries so I think the issue lies in the way it gets generated. Any help would be appreciated.