Deleted etc folder from router, not able to get inside the router config

Unknowingly deleted etc folder from the tp-link MR3420 v2 router, now i am not able to get into the router using web browser. is there anyway to reinstall the firmware or recover the old. only the setting button in my route blinks. should do.


I am using windows 10 OS. linux cmd doesn't work. not able to do it. just power button in on and setting button keeps blinking. reset button doesn't works. few hours ago everything works fine. i was trying to revert to old original Tp-link fireware using WinSCP, so no space is available to install so deleted tmp content and etc folder thought it is not of much use. as soon as i deleted it. got disconnected and not able to connect to my router.

Try tftpd recovery from


Windows Subsystem for Linux 2 (WSL 2) is a Linux Kernel that runs on Windows through virtualisation.


Tried several times not working. Setting led light keeps blinking continuously. not showing any log also in Tftpd64. no firewall is set for it. Still no progress.

The scripts that implement the OpenWrt failsafe and reset to default modes are in /etc, so that is not going to work.

Plug in the power while holding the reset button down. If after several seconds only the WPS light is on that means bootloader TFTP recovery has started. Also try that with the WPS button.

If your bootloader does not have TFTP recovery mode, you will need to use serial.

This one works . My router is back to original firmware. Thanks a lot.

Correct, but they are executed before the overlay gets mounted, so unless we're talking about ext4 (or jffs2-) based images, failsafe will work regardless.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.