Default gateway problem

Hello, I have problem with new fw version. I cant get automatically default gateway from my provider, but for older version 17.01.4 all work. if i set static router i get internet but it must works automaticle.
Help me pls

You must provide some more information:

Router: (make and model + version)?
FW version: ?
Internet provider: ?

1 Like

This problem has any routers with fw 17.01.5 or later. 17.01.4 wokring good. My internet provider provides internet with dhcp. my dhcp client must geting static routers from provider, but it not works with new fw.
1 on this screenshot u cant see default roure 0.0.0.0/0 and its my problem with new fw.

1

You didn't any provide this information. From the IP, the provider appears to be AS197901. From the MAC, it appears to be a TP-Link.

  • I see you're using 8.8.8.8, what happens when you request the DNS servers from your provider?

The "IPv4-Gateway" column in the screen shot suggests that you have a default route of 146.120.31.254

What is the output of

ip -4 route

What is the "WAN" section of your /etc/config/network ?

(ISP is likely Cogent)

1 Like

https://bgp.he.net/AS197901
Lists: 146.120.31.0/24 PE Okolita Aleksandr Valer'evich (Czech Republic)

Upstream ISP: Dataline LLC Ukraine AS35297

1 Like

Consistent with last-resolved hop of dataline.demarc.cogentco.com

1 Like

Yep, it seems to be a stub of a stub, one of their upstreams are Cogent.

it is dns from dhcp

1 Like

root@LEDE:~# ip -4 route
146.120.24.0/21 via 146.120.31.254 dev eth0 src 146.120.25.73
192.168.1.0/24 dev br-lan scope link src 192.168.1.1
in this /etc/config/network file all by defaults I install clear firmware

At any point, did you make a 0.0.0.0/0 static route and remove it while the router was booted?

yep, it is with my static route, and i have internet
root@LEDE:~# ip -4 route
default via 146.120.31.254 dev eth0
146.120.24.0/21 via 146.120.31.254 dev eth0 src 146.120.25.73
192.168.1.0/24 dev br-lan scope link src 192.168.1.1

If you delete the static route while the router is on, it will not recreate it until you reboot.

Workaround: I make the equivalent of a default route when testing and using VPNs by creating the following 2 more-specific routes instead:

  • 0.0.0.0/1
  • 128.0.0.0/1

I'm curious what has changed since version 17.01.4 & 17.01.5. In 17.01.4, everything works well.

If you mean the default route delete-able from LuCI - I'm not sure.

I noticed it when running Wireguard in version 18 and testing routes. I noticed that I made a route to a Wireguard interface for testing and deleted the route. I observed the default route was missing.

I'm certain I've did this in version 17 and the default route didn't disappear; but I cannot confirm that.

Hi all! I have a problem with TP-LINK mr3020 rev 1.9 portable router and its default gateway. I was configured it with static default gateway 192.168.0.1 but I didnt wait till the end of saving that configuration and plug the power off. I have used it before for picking internet connection from my mobile phone hotspot and that works like before but I cannot access to router settings over default gateway 192.168.0.1 or 192.168.1.1. If I connect it with ethernet to my pc and type ipconfig I get the screen where it says it dont read default gateway IP adress. There is ipv4 adress which isnt accessible through internet browser, subnet mask is 255.255.0.0 I dont know what to do now? tapatalk_1556977743041

@bagosh, welcome to the community!

Please make a new thread for your issue, as your problem seems unrelated to the Original Post.

1 Like

How it is not related with original thread? I have a problem with default gateway but ok I will start new thread.

1 Like

You seem to have an issue renumbering your router. The OP had issues with routes.

In your case, the device just happens to be the default gateway of the Windows machine you pictured.

I would hardly classify your issue as a "default gateway problem," just because it's the router.