Decrypting the DIR-2640 stock firmware

Hi guys,
I'm testing openwrt for my Dlink DIR-2640 A1 since a couple of days and i'm really liking it.

But i want to have the option to revert back to the stock firmware

I tried to use this python script recommended on the wiki page to decrypt the stock firmware with no success.
Getting syntax error every time >>> ./ -i </src/1.bin> File "<stdin>", line 1 ./ -i </src/1.bin> ^ SyntaxError: invalid syntax

Can someone please help me to use it correctly?

Just use the D-Link Recovery GUI

Some reported having to use a Windows based browser when encountering OpenWrt installation issues, so you can give that a try if encountering problem reverting to stock firmware as well.

Thanks for the answer but as mentioned on the wiki page

For newer devices, however, this isn't an option, as only encrypted SHRS firmwares are publicly available. If you own one of these devices and needs the firmware in unencrypted format to use with the emergency recovery mode, you'll have to resort to tools like dlink-decrypt in order to manually decrypt the SHRS firmwares provided by D-Link.

Already tried uploading the stock firmware but failed

this is the outcome
I don't have a DIR-2640 to test it
let me know how how you go with it

Thank you very much :blush: :blush: :pray: :pray:. I'll test and get back to you.

Would you mind giving the exact python command as the docs seem a little bit confusing to me.

./ -i inputfilename -o outputfilename

the file worked perfectly i reverted back to stock (awkwardly with same old setings).
Thank you very much for your help.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.