Debugging SQM to Eliminate Bufferbloat

Every now and again, someone posts a question expressing trouble setting up their SQM/QoS in LEDE. They're hoping to eliminate the lag/latency caused by Bufferbloat in their router.

If you're in this situation, follow the SQM Howto at If you don't have success (or you get paradoxical results), we're happy to help, but are going to want to know the answers to a few questions:

  • What brand/model router do you have?
  • What version of OpenWrt/LEDE are you using?
  • How do you connect to the internet? Cable? DSL, other?
  • What's your nominal/expected/advertised download speed? Upload speed?
  • If you turn off all QoS/management, what are your measured download/upload speeds? (We like to use - it's robust, accurate, and doesn't rely on Flash...)
  • What is the WAN "interface name" in the Network -> Interfaces page? (its name is in the red box below "WAN" on that page)
  • What parameters do you see in the Network -> SQM-QoS values? The most important are:
    • Enable this SQM instance (should be checked)
    • Interface name (should be the same as the "WAN interface name" from above)
    • The number entered for Download Speed (in kbps)
    • The number entered for Upload Speed (in kbps)
    • Queue discipline (default is "piece of cake" if it's a new build, or fq_codel)
    • Set "Which Link Layer to account for:"
      • If you're on cable, should be "none"
      • If you're using DSL/ADSL, should be "ATM", and Per-Packet Overhead (in the Link Adaptation tab) should be 44
      • If you're using VDSL2, should be Ethernet with overhead and Per-Packet Overhead should be 8

Copy the questions above and paste them into a new topic in this forum. Then try again and look at the "Results and Share" to see the latency values, and add a link to that page to share your results.

Update: Fixed LEDE/OpenWrt name and URL to the SQM Howto